When using Bugzilla, flag fields are not updated by clicking "Refresh" on a modified bug

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
8 years ago
8 years ago

People

(Reporter: Vitaliy Filippov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; ru) Presto/2.2.15 Version/10.10
Build Identifier: 3.5.5

That's not a duplicate of Bug 221036.
  Because 1)
I tried to set browser.cache.check_doc_frequency=1, but no luck.
I discovered that Bugzilla does not send Expires header, and tried to add it (already expired, i.e. date in the past) - still no luck.
Same with Cache-Control header.
  and 2)
After updating the second tab, the form itself IS updated, but the flag field IS NOT.
  and 3)
LiveHTTPHeaders says Firefox DOES re-request the page.

Reproducible: Always

Steps to Reproduce:
1. Open some bug from Bugzilla.
2. Set some flag on it.
3. Open bug in two tabs.
4. Clear flag in one tab.
5. Switch to another tab and click Update (or hit F5, or Ctrl-R).

Actual Results:  
Look at the flag field - it is not updated, but the form itself IS! (for the proof - look at the value of delta_ts hidden input).
So if you enter some changes into this form and click Commit, the cleared flag is RESET again WITHOUT conflicts!

Expected Results:  
ALL form fields MUST be updated when updating the page.
(Reporter)

Comment 1

8 years ago
Trying to test it in this specific Bugzilla instance.
Flags: in-litmus?
(Reporter)

Comment 2

8 years ago
Test
Flags: in-litmus?
(Reporter)

Comment 3

8 years ago
Hmm...
Didn't reproduce here. :(

Comment 4

8 years ago
That's the expected behavior, see bug 46845 and its tens of dupes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 46845
You need to log in before you can comment on or make changes to this bug.