Offline mode should allow loading of local URLs

RESOLVED DUPLICATE of bug 87717

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 87717
8 years ago
8 years ago

People

(Reporter: Pascal Sartoretti, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2b3) Gecko/20091115 Firefox/3.6b3

Current behavior :
When Firefox has no network connection, it automatically goes into "Offline" mod and refuses to load pages. This is problematic in the following use cases:
- when using e.g. Google Desktop, which displays its results in a web page loaded via 127.0.0.1.
- for web developers working offline and testing applications (minor problem, see workaround).

Many users have raised the problem (see e.g. https://bugzilla.mozilla.org/show_bug.cgi?id=440527).

Current workaround :
The user must manually exit the offline mode to load such pages; this is misleading, because the user will then get errors when loading remote pages.

Proposed solution :
When in offline mode, Firefox should accept to load local pages (localhost or 127.0.0.1)

Reproducible: Always

Comment 1

8 years ago
Appears to be a duplicate of Bug 87717
(Reporter)

Comment 2

8 years ago
Yes, a dupe.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 87717
You need to log in before you can comment on or make changes to this bug.