Last Comment Bug 531056 - [HTML5] Remove <spacer> support
: [HTML5] Remove <spacer> support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: P3 normal with 1 vote (vote)
: ---
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26)
:
Mentors:
Depends on: 531030 559023
Blocks: 597376
  Show dependency treegraph
 
Reported: 2009-11-25 06:00 PST by Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26)
Modified: 2010-10-07 00:54 PDT (History)
7 users (show)
hsivonen: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make the parser unaware of <spacer> (49.29 KB, patch)
2010-09-09 08:12 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26)
jonas: review+
jst: approval2.0+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2009-11-25 06:00:09 PST
<spacer> support in gone in the spec. However, can't remove the parser support unless layout support is removed, too.
Comment 1 d 2009-12-19 03:46:13 PST
I'm all for using better solutions than deprecated tags, but I thought we were keeping everything we already supported to not break compatibility with older sites?

See http://en.wikipedia.org/wiki/Comparison_of_layout_engines_%28Non-standard_HTML%29 for what we support that is deprecated.
Comment 2 d 2009-12-19 03:57:09 PST
Ah, I just saw bug 531030, and had missed that it was proprietary, not deprecated. As they say, kill it. But, there are still some inconsistencies in what we do, as you can see in the previous link. How about <blink>, <image>, <keygen> (now a HTML5 attribute?), <marquee> (probably a keeper since it's still pretty common in use), <nobr>, <noembed>, <nolayer> and <wbr>?
Comment 3 Jeff Muizelaar [:jrmuizel] 2010-07-19 14:03:05 PDT
For what it's worth our <spacer> support currently breaks http://caribana.com/
Comment 4 Jeff Muizelaar [:jrmuizel] 2010-07-19 14:05:23 PDT
In more detail,

They have code that does:

<td height="938" width="6"><spacer type="block" width="938"></td>

which causes a table cell to be much larger in Firefox than in other browsers. 

This code seems to come from Adobe PageMill
Comment 5 [Baboo] 2010-08-20 06:57:13 PDT
Allowing proprietary tags only in quirks mode is not an option?
Comment 6 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-08-23 07:55:48 PDT
(In reply to comment #5)
> Allowing proprietary tags only in quirks mode is not an option?

Evidence (the behavior of other browsers) suggests that it's not needed, so there's no point in introducing that kind of complexity.

Assigning to self now that the layout side has been fixed.
Comment 7 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-09 08:12:01 PDT
Created attachment 473550 [details] [diff] [review]
Make the parser unaware of <spacer>

A test case will land as part of bug 559023.
Comment 8 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-15 01:31:02 PDT
Comment on attachment 473550 [details] [diff] [review]
Make the parser unaware of <spacer>

Requesting approval for 2.0: We already got rid of <spacer> layout support and this low-risk patch makes the parser match the spec on <spacer>. Taking this fix makes tracking standards-compliance easier, since the test between 2.0 and trunk wouldn't need to diverge if we had this patch on both.
Comment 9 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-17 04:35:05 PDT
http://hg.mozilla.org/mozilla-central/rev/bc15c280c430

As mentioned earlier, the test case is part of bug 559023.
Comment 10 Mozilla RelEng Bot 2010-09-17 12:41:22 PDT
A changeset from this bug was associated with a Dromaeo (DOM) regression. boo-urns :(

  Previous: avg 247.699 stddev 3.468 of 30 runs up to 268ef4ccb5ff
  New     : avg 238.140 stddev 1.402 of 5 runs since bc15c280c430
  Change  : -9.559 (-3.86% / z=2.756)
  Graph   : http://mzl.la/92KXJ4

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=bc15c280c430

The tag [suspect-regress-dromaeo_dom] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Comment 11 Mozilla RelEng Bot 2010-09-17 12:47:10 PDT
A changeset from this bug was associated with a Dromaeo (jslib) regression. boo-urns :(

  Previous: avg 133.289 stddev 2.396 of 30 runs up to 268ef4ccb5ff
  New     : avg 123.541 stddev 0.943 of 5 runs since bc15c280c430
  Change  : -9.748 (-7.31% / z=4.068)
  Graph   : http://mzl.la/9hGqIo

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=bc15c280c430

The tag [suspect-regress-dromaeo_jslib] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Comment 12 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-17 13:40:03 PDT
The bot must be confusing this bug ith the other one in the same push: bug 531056.
Comment 13 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-17 13:40:57 PDT
Doh. Bug 591981 that is.
Comment 14 Mozilla RelEng Bot 2010-09-17 14:26:03 PDT
A changeset from this bug was associated with a Dromaeo (CSS) regression. boo-urns :(

  Previous: avg 2081.901 stddev 35.646 of 30 runs up to 268ef4ccb5ff
  New     : avg 1986.498 stddev 14.409 of 5 runs since bc15c280c430
  Change  : -95.403 (-4.58% / z=2.676)
  Graph   : http://mzl.la/ba6Hsw

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=bc15c280c430

The tag [suspect-regress-dromaeo_css] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Comment 15 Mozilla RelEng Bot 2010-09-17 14:26:17 PDT
A changeset from this bug was associated with a Dromaeo (DOM) regression. boo-urns :(

  Previous: avg 246.591 stddev 2.979 of 30 runs up to 268ef4ccb5ff
  New     : avg 233.803 stddev 2.192 of 5 runs since bc15c280c430
  Change  : -12.788 (-5.19% / z=4.292)
  Graph   : http://mzl.la/brFt7U

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=bc15c280c430

The tag [suspect-regress-dromaeo_dom] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Comment 16 Mozilla RelEng Bot 2010-09-17 14:26:26 PDT
A changeset from this bug was associated with a Dromaeo (jslib) regression. boo-urns :(

  Previous: avg 130.889 stddev 2.485 of 30 runs up to 268ef4ccb5ff
  New     : avg 121.915 stddev 0.830 of 5 runs since bc15c280c430
  Change  : -8.975 (-6.86% / z=3.612)
  Graph   : http://mzl.la/bVrIoj

The regression occurred from changesets in the following range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=bc15c280c430

The tag [suspect-regress-dromaeo_jslib] has been added to the status whiteboard;
please remove it only once you have confirmed this bug is not the cause
of the regression.
Comment 17 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-09-17 14:36:32 PDT
There's no way the patch for this bug could have been the one causing the regression, since Dromaeo probably isn't stress-testing <spacer>.
Comment 18 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2010-10-07 00:54:36 PDT
Test landed as part of bug 559023.

Note You need to log in before you can comment on or make changes to this bug.