[Windows] Enabling a extension results in "deep recursion on subroutine" warnings

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Extensions
--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Michael Thomas (Mockodin), Assigned: Max Kanat-Alexander)

Tracking

3.5.2
Bugzilla 3.6
All
Windows Server 2008
Bug Flags:
approval +

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
Created attachment 414522 [details]
Perl Command Line Interpreter has stopped working

Also Applies to Windows 7 (and likely Windows Vista)

Code Base: CVS TIP 3.5.2+

Reproducible Always

To Reproduce:
1. delete extensions/Example/disabled
2. Run checksetup or if in a mod_perl environment apache -t

Results:
Deep recursion on subroutine "Bugzilla::Extension::__do_call" at Bugzilla/Extension.pm line 189.
Deep recursion on subroutine "Bugzilla::Extension::__do_call" at Bugzilla/Extension.pm line 159.
Deep recursion on anonymous subroutine at C:/usr/lib/File/Spec/Win32.pm line 92.
Deep recursion on subroutine "Bugzilla::Extension::__do_call" at Bugzilla/Extension.pm line 153.
Deep recursion on subroutine "Bugzilla::Extension::my_inc" at Bugzilla/Extension.pm line 210.
Deep recursion on subroutine "File::Spec::Win32::case_tolerant" at Bugzilla/Extension.pm line 166.

Followed by windows "Perl Command Line Interpreter has stopped working"

Notes:
If no extensions are enable, no errors occur.

Comment 1

8 years ago
I can reproduce this problem on Windows 7, but not on Linux.
Target Milestone: --- → Bugzilla 3.6
(Assignee)

Updated

8 years ago
Severity: blocker → critical
Hardware: x86 → All
Summary: Enabling a extension results in Perl Command Line Interpreter has stopped working with Deep recursion on subroutine warnings → [Windows] Enabling a extension results in "deep recursion on subroutine" warnings
(Assignee)

Updated

8 years ago
Depends on: 524229
(Assignee)

Comment 2

8 years ago
Yeah, I can reproduce it too. It's probably somehow related to the path stuff that Extensions do. I'll look at it tonight or tomorrow if I get the chance.
(Assignee)

Comment 3

8 years ago
Created attachment 415321 [details] [diff] [review]
v1

Okay, this fixes it in my testing. mockodin, would you let me know if it fixes it for you? I think that since I'm the Extensions owner, that will be enough review to check in this fix.
Assignee: extensions → mkanat
Status: NEW → ASSIGNED
Attachment #415321 - Flags: review?(mockodin)
(Reporter)

Comment 4

8 years ago
Looks good. Apache is now starting properly. Thanks MKanat.
(Reporter)

Updated

8 years ago
Attachment #415321 - Flags: review?(mockodin) → review+
(Assignee)

Comment 5

8 years ago
Checking in Bugzilla/Extension.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Extension.pm,v  <--  Extension.pm
new revision: 1.8; previous revision: 1.7
done
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 6

8 years ago
This bug has no approval+, for the record. ;)
Flags: approval?
(Assignee)

Comment 7

8 years ago
Oh, thanks, LpSolit. :-)
Flags: approval? → approval+
You need to log in before you can comment on or make changes to this bug.