file attachment: mac 8 bit characters do not encode correctly with .txt extension

VERIFIED DUPLICATE of bug 22090

Status

MailNews Core
MIME
P3
normal
VERIFIED DUPLICATE of bug 22090
17 years ago
9 years ago

People

(Reporter: pmock, Assigned: rhp (gone))

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build Date & Platform Bug Found: 
 macos commercial seamonkey build 2000-091808-m18 installed on G3/400 OS 9.04

Overview Description: 
 If you send a message containing a file attachment that contain Mac 8 bit 
accent characters and name the file with a .TXT extension, the accent character 
are not encoded correctly.

Note: it does not matter if you file attachment contains a mac resource fork.  
If you do not add the .txt file extension, this problem does not occur.

Steps to Reproduce: 
1) Outside seamonkey, create a text file which contains accented 8 bit 
characters. I used bbedit to create my text file.  On the mac, to create 8 bit 
characters, you can use the Apple Key Caps program to copy and paste characters 
or type the following
 option+e, e for an accented e
 option+e, a for an accented a
 option+e, i for an accented i
 option+e, o for an accented o
 option+e, u for an accented u
2) Launch Mac seamonkey
3) Open mail
4) Start a html or plain text message.
   Use the plain text editor to keep it simple.
5) Address the message to yourself
6) Add a subject title.
   My subject title did not include accented charactesrs
7) Add some text to the message body.
   It does not matter if you add accented characters
8) Send the message 
9) In Communicator or seamonkey, retrieve the message
   The text attachment is displayed inline.  The mac characters have not been 
encoded properly.
10) View the page source
    The page source contains 

11) In communicator 4.7, send the same attachment to yourself
12) Compare the page source
    The context type is different.

Actual Results: 
 In seamonkey and communicator 4.7, the .txt file attachment display inline with 
the 8 bit characters not encoded properly.

Expected Results: 
 It should behavior like 4.7 and display the Mac 8 bit character correctly

Additional Builds and Platforms Tested On: 
 Mac release of communicator 4.74 professional build.

Additional Information:
 -It does not matter if the text file name contain accented characters.
 -It does not appear to matter if you sent the message as plain text or html or 
use the intellient send option to convert to sent as "html only", "plain text 
only", or "html and plain text".
 -This problem does not appear to occur with mac 8 bit characters entered in the 
message body, just the file attachment that contains 8 bit or accented 
characters.

 => Mind twister part - in seamonkey, if you use the paperclip icon to open the 
attachment, it opens a browser window and displays the wrong characters.  If you 
 save the file, the file is decoded and the right mac 8 bit character are 
contained in the file.  (ack ... my head is hurts now...)
(Reporter)

Updated

17 years ago
QA Contact: esther → pmock
(Assignee)

Comment 1

17 years ago
I believe this is actually a problem with handling Apple Double files. We don't 
do that correctly and I think this is a side affect of that.

- rhp

*** This bug has been marked as a duplicate of 22090 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
Ok Rich :)
Verified bug as a duplicate of bug 22090.
Status: RESOLVED → VERIFIED
Product: MailNews → Core

Updated

13 years ago
OS: Mac System 9.x
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.