Closed Bug 5314 Opened 24 years ago Closed 21 years ago

Accept-Charset for form is not implement.

Categories

(Core :: Internationalization, defect, P2)

All
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 5313

People

(Reporter: ftang, Assigned: erik)

References

()

Details

(This bug imported from BugSplat, Netscape's internal bugsystem.  It
was known there as bug #56223
http://scopus.netscape.com/bugsplat/show_bug.cgi?id=56223
Imported into Bugzilla on 04/20/99 12:50)


Split from Bug 48964:
From: http://www.nagual.ru/~ache/n4w95.html#bug_list
1) Netscape not decode <FORM>s input from CP1251 (Russian Windows
default character set) to KOI8-R when needed. I.e. it totally
ignores ACCEPT-CHARSET="KOI8-R" <FORM> attribute and global HTML
page character set too for both <META> and HTTP header cases. See
Internationalization of the Hypertext Markup Language (RFC 2070)
for details. Look at http://www.nagual.ru/~ache/main.html#form_input
to see this bug in action.
*** Bug 48964 has been marked as a duplicate of this bug. ***
We don't plan to support Accept-Character in FORM according to the Multilingual
HTML RFC in Dogbert. Later this.
Per 6/30 I18n Latered Bug Meeting, this bug is marked as WONTFIX.
We should do review of RFC specs compliance and this bug should be
marked as a duplicate of that bug.
*** This bug has been marked as a duplicate of 75280 ***
Duplicate bug, bulk Verified
This bug will be moved over to 5.0 for a review.
It is true that we don't do anything with Accpet-Charset
attribute for Form Input and TextArea.

The relevant section of the RFC 2070 is "5.1 DTD additions". This does
not seem to be a requirement but rather a recommendation for a user
agent. The recommended action upon encountering the Accept-Charset
attribute would be:

1) a warning to the user about what charset the form can accept, or
2) restrict the input charsets to those listed as the attribute values.

We need to decide if we should follow this requirement.
This bug has been moved over to Bugzilla.  It has a Bugzilla id of 5313
(http://bugzilla.mozilla.org/show_bug.cgi?id=5313)
I guess this got imported twice.  Reopening to mark as a dup of bug 5313.
Status: CLOSED → REOPENED

*** This bug has been marked as a duplicate of 5313 ***
Status: REOPENED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
vrfy dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.