Closed Bug 531558 Opened 11 years ago Closed 10 years ago

Firefox.exe left in memory constantly

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: csapino, Unassigned)

Details

(Keywords: hang)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)

firefox.exe is being left in memory about 75% of the time as evidenced by task manager. Thus it won't re-start until it is removed by deleting the process.
Cannot launch multiple copies of firefox

Happens with xp/pro, xp home and Vista on my three computers about 75% of the time.

Reproducible: Sometimes

Steps to Reproduce:
1. Launch it and then exit
2. Attempt to launch multiple copies of firefox
3.
Actual Results:  
I normally launch it from the toolbar


This product is so useless I cannot use it in its present form.

I have been using firefox since it has been released and have never seen it this bad!

I've temporarily switched to Chrome and I have had zero problems with it.
Having encountered and reported a similar problem, I took a look at reported bugs. This one appears to quite widespread. It appears that 408201, 454021, 543955, 493909, 539262 and 456589 may describe this in various ways; and it is possible that 507964 also is related.
Normally one can launch multiple copies of Firefox, and I have just done so. When this problem arises the second copy will not start; and a window pops up saying ff is already running. Having used ff, closed it, and done something else and closed that also, so that one has a bare desktop, double clicking on the ff shortcut icon will produce the problem. However the problem is intermittent.
When I closed ff after last report, and re-opened, the problem came up again. I waited for about a minute before killing the process.
Very high memory usage as well; in the range of 100MB to 200MB.
This problem may be caused by the Zone alarm toolbar that is installed by the Zone Alarm Pro suite. Another issue with this toolbar is that you cannot launch multiple copies of Firefox. When I uninstalled the toolbar, the problem went away. It took me quite awhile to figure this out. Since I uninstalled the toolbar, I have had no problems whatsoever with Firefox being retained in memory or launching multiple instances of it.
Keywords: hang
I have disabled several 'safe' add-ons, and the problem went away.
currently using only adblock plus, betterprivacy, british english dictionary, fireftp and logmein.
John, thanks for updating the bug.
invalid per comment 7
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.