Closed Bug 531592 Opened 11 years ago Closed 11 years ago

Provider for calendar could not be found

Categories

(Calendar :: General, defect)

x86_64
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 529853

People

(Reporter: andrew, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091112 Gentoo Firefox/3.5.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.5) Gecko/20091129 Lightning/1.0pre Thunderbird/3.0

I've built Thunderbird 3.0rc1 with lightning. On launching Thunderbird an error appears and the default calendar is not writable. Attempting to create a new calendar gives the same error. 

Reproducible: Always

Steps to Reproduce:
The way I was trying to create a new calendar was:
1: Events and Tasks -> Calendar
2: Right-click in the Calendar list, select "New Calendar"
3: In the wizard, select "On My Computer" and hit "Next"
Actual Results:  
The error dialogue appears

Expected Results:  
A new calendar to be created

The error is:

An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.

Error code: 0x80004005
Description:
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageStatement.reset]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///usr/lib64/mozilla-thunderbird/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calStorageUpgrade.jsm :: ensureUpdatedTimezones :: line 380"  data: no]
Product: Thunderbird → Calendar
QA Contact: general → general
Seems that you build based on old Lightning source code that doesn't contain the fix for Bug 529853. Ensure that you are building your Lightning package from the latest comm-1.9.1 source code.
@Stefan: Certainly looks like a duplicate of https://bugzilla.mozilla.org/show_bug.cgi?id=529853. I'll file a bug over at the Gentoo BTS as I installed TB3.0rc1 using the ebuilds from the mozilla overlay.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529853
You need to log in before you can comment on or make changes to this bug.