Closed Bug 531598 Opened 10 years ago Closed 10 years ago

Tab drag and drop reloads Flash

Categories

(Firefox :: General, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 449734

People

(Reporter: atreyas, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Facing this with flash with Video sites. When a tab gets dragged and opened in a new window, several times the flash video completely refreshes starting from the beginning. It's annoying when the players don't support play from the middle.
With a trackpad, this happens too often due to click and movement being co-located. Also happens while switching to the tab and accidentally dragging it.

As a note: Saw the 3.7 changes the way these plugins works, but does it make it independent. I mean, can plugins be made to integrate through a layer in between, so that the frontend is independent. I believe this might even reduce crashes and prevent such issues.

Reproducible: Always

Steps to Reproduce:
1. Open a site. e.g. http://www.animefushigi.com/full-anime-list/on-going-anime/86-full-metal-alchemist-brotherhood
2. Open a flash video on the site that does not allow play from middle (e.g. jwplayer)
3. Drag the tab into an empty area so that it opens in a new window.
Actual Results:  
the video starts from scratch.

Expected Results:  
Video must continue playing from where it was left.

Keep all the page information as in the tab, in the new window. there are no issues when moving the tab int he same window. Happens only if it's a new window.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449734
You need to log in before you can comment on or make changes to this bug.