Need to add licensing info from chromium to about:license

RESOLVED FIXED

Status

()

Core
General
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Benjamin Smedberg, Assigned: gerv)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 beta1+, status1.9.2 .4-fixed)

Details

(Whiteboard: [fixed-lorentz])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
The BSD boilerplate from imported Chromium code (for electrolysis) needs to be added to about:license.

bent, it appears that we didn't import the LICENSE file from chromium along with the code (the BSD header references a LICENSE file). Could you find and import that file so that gerv can make the necessary changes to about:license?
Added mozilla/ipc/chromium/src/LICENSE in changeset 7d9f0fb8ccda.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

9 years ago
->gerv to actually update license.html or whatever makes about:license correct.
Assignee: bent.mozilla → gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

9 years ago
Duplicate of this bug: 534949
It's not just Chromium either... ipc/chromium/src/third_party/libevent/ has a completely different license than what Chromium normally uses. There may be others, too.
Status: REOPENED → NEW
OS: Windows 7 → All
Hardware: x86 → All
Version: Other Branch → Trunk
Created attachment 417815 [details] [diff] [review]
Patch v.1

Here's a patch adding the Chromium and libevent licenses. Has anyone found any more? I had a poke around the ipc/ directory and couldn't find any.

Gerv
I will take silence as denial. Fixed on trunk:
http://hg.mozilla.org/mozilla-central/rev/b2b5f07a77ea

Gerv
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Blanket approval for Lorentz merge to mozilla-1.9.2
a=beltzner for 1.9.2.4 - please make sure to mark status1.9.2:.4-fixed
(Reporter)

Comment 9

8 years ago
Merged into 1.9.2 at http://hg.mozilla.org/releases/mozilla-1.9.2/rev/84ba4d805430
status1.9.2: --- → .4-fixed
You need to log in before you can comment on or make changes to this bug.