Maemo multilocale builds should abort on failed locale repacks

RESOLVED FIXED

Status

Release Engineering
General
P3
normal
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile][l10n][mozharness])

(Reporter)

Description

8 years ago
Since the November 28th nightlies these builds have been turning red, but still completing and uploading their builds - so it seems like unnecessary redness.

I asked Armen and he said it looked like string changes causing the problems. Specific errors look like this:
          -s /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/mobile/locales/en-US/searchplugins \
          -s /home/cltbld/build/maemo-1.9.2-nightly/releases/l10n-mozilla-1.9.2/it/mobile/searchplugins \
          -t /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2 -f jar  -c /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/objdir/merged/mobile -c /home/cltbld/build/maemo-1.9.2-nightly/releases/l10n-mozilla-1.9.2/it/mobile -c /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/mobile/locales/en-US tmp-search.jar.mn
processing tmp-search.jar.mn
Traceback (most recent call last):
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 498, in <module>
    main()
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 495, in main
    localedirs=options.l10n_src)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 286, in makeJars
    jardir=jardir)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 231, in makeJar
    localedirs)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 352, in processJarSection
    outHelper, jf)
  File "/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/config/JarMaker.py", line 384, in _processEntryLine
    raise RuntimeError('File "%s" not found in %s' % (src, ', '.join(src_base)))
RuntimeError: File "ebay-it.xml" not found in /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/mobile/locales/en-US/searchplugins, /home/cltbld/build/maemo-1.9.2-nightly/releases/l10n-mozilla-1.9.2/it/mobile/searchplugins, /home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/objdir/mobile/mobile/locales, .
make[1]: *** [searchplugins] Error 1
make[1]: Leaving directory `/home/cltbld/build/maemo-1.9.2-nightly/mozilla-1.9.2/objdir/mobile/mobile/locales'
make: *** [chrome-it] Error 2


If it is indeed just changed strings causing burning we should make these steps non-red (orange, maybe?).

Comment 1

8 years ago
This is not a string change, but a build bustage, and should be red.

I reopened bug 521996, which actually landed a wrong patch, resolving this as dupe.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 521996
(Reporter)

Comment 2

8 years ago
Why should it be red when the build continues? Red is for fatal things...
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

8 years ago
Then it should abort on red.

Comment 4

8 years ago
I think this could be seen as a dup of bug 525327... l10n repacks go red on string issues, but builds go red only on fatal errors.  Splitting the factory would allow for both.

Comment 5

8 years ago
Futuring until we get to it.
Component: Release Engineering → Release Engineering: Future

Comment 6

8 years ago
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3

Updated

8 years ago
Whiteboard: [mobile][l10n]

Updated

8 years ago
Assignee: nobody → aki

Updated

8 years ago
Summary: Maemo 1.9.2/m-c nightly builds are turning red with locale errors → Maemo multilocale builds should abort on failed compare-locales

Comment 7

8 years ago
aki, your summary change is not correct, this is about locale errors that are *not* compare-locales.

Updated

8 years ago
Summary: Maemo multilocale builds should abort on failed compare-locales → Maemo multilocale builds should abort on failed locale repacks

Comment 8

7 years ago
We should get this for free with bug 525327.
Whiteboard: [mobile][l10n] → [mobile][l10n][mozharness]

Comment 9

7 years ago
Fixed for nightlies.  Releases are tracked in bug 574764.
Assignee: aki → nobody
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.