If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Some crashes just report "(signature unavailable)"

RESOLVED DUPLICATE of bug 527095

Status

()

Toolkit
Crash Reporting
RESOLVED DUPLICATE of bug 527095
8 years ago
8 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [crashkill])

(Reporter)

Description

8 years ago
For some reason a number of crashes are just reported as "(signature unavailable)". Dbaron noted that some previous investigation indicated this was not a Socorro problem, but that the breakpad output (or minidumps?) were unable to show a stack.

Over in bug 528798 comment 40 and 41, Tomcat was able to reproduce a particular crash with Zone Alarm which shows up as "signature unavailable", yet was able to get stacks via windgb. Hopefully this will help with understanding what's causing this problem?
(Reporter)

Updated

8 years ago
Whiteboard: [crashkill]
Ted: Is this something we need to file upstream?
There are two specific things I know that can cause this:
1) A completely malformed minidump, not much we can do about that without out-of-process minidump generation
2) A minidump that's just missing the bit that indicates what thread crashed (this may still be malformed enough to be useless)

If these are occurring on Windows, then there isn't anything we can fix upstream, we just use a Microsoft API to write minidumps. Out of process dump generation is the only hope.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 527095
You need to log in before you can comment on or make changes to this bug.