LDAP address book named with cyrillic/chinese letters doesn't work

VERIFIED FIXED in Thunderbird 3.1a1

Status

MailNews Core
LDAP Integration
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: Alexander L. Slovesnik, Assigned: standard8)

Tracking

({fixed-seamonkey2.0.3, regression})

1.9.1 Branch
Thunderbird 3.1a1
All
Windows XP
fixed-seamonkey2.0.3, regression
Bug Flags:
blocking-thunderbird3 -
in-testsuite +

Firefox Tracking Flags

(blocking-thunderbird3.0 .1+, thunderbird3.0 .1-fixed)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Created attachment 415452 [details]
Part of prefs.js from Thunderbird 3.0 (bug is present)

STR:
1. Create LDAP address book and enter cyrillic letters in "Name" field
2. Try to search something in LDAP address book

Actual results:
Nothing found  

Actual results:
Some e-mail addresses are found  

This error doesn't present in Thunderbird 2.0
Flags: blocking-thunderbird3?
(Reporter)

Comment 1

8 years ago
Created attachment 415453 [details]
Part of prefs.js from Thunderbird 2.0 (bug is not present)
(Reporter)

Updated

8 years ago
OS: Mac OS X → Windows XP

Comment 2

8 years ago
Works for me just fine on
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0.
What your LDAP server is? Could you get ldap log?
https://wiki.mozilla.org/MailNews:Logging
OS: Windows XP → Mac OS X
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Works for me just fine on
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091121
> Thunderbird/3.0.
> What your LDAP server is? Could you get ldap log?
> https://wiki.mozilla.org/MailNews:Logging
Can you test Russian version of Thunderbird 3.0? I'll get to LDAP server on work only tomorrow.
OS: Mac OS X → Windows XP

Comment 4

8 years ago
No problem here too
Mozilla/5.0 (Windows; U; Windows NT 6.1; ru; rv:1.9.1.5) Gecko/20091121 Thunderbird/3.0

Updated

8 years ago
Version: unspecified → 3.0
(Reporter)

Comment 5

8 years ago
Screencast, showing bug, is available for download at http://ragnaar.com/projects/thunderbird_ldap.avi
Chinese letters also cause problem. FWIW there is no problem on Mac OS X, looks like it's windows-only. I didn't test Linux, though.
Summary: LDAP address book named with cyrillic letters doesn't work → LDAP address book named with cyrillic/chinese letters doesn't work
We can't block on this unless we can figure out reliable steps to reproduce this, or at least get a better feel for what's going on here.  An LDAP log might help.  Adding qawanted flag and a few CCs in the hopes of getting more folks to try to reproduce.
Flags: blocking-thunderbird3? → blocking-thunderbird3-

Comment 7

8 years ago
(In reply to comment #5)
> Screencast, showing bug, is available for download at
> http://ragnaar.com/projects/thunderbird_ldap.avi
> Chinese letters also cause problem. FWIW there is no problem on Mac OS X, looks
> like it's windows-only. I didn't test Linux, though.

ALexander,
Please provide ldap log I've asked for because I can't reproduce it on Windows XP or Windows 7 with Active Directory LDAP.
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> ALexander,
> Please provide ldap log I've asked for because I can't reproduce it on Windows
> XP or Windows 7 with Active Directory LDAP.
LDAP log - http://ragnaar.com/projects/ldap.log
Screencast of logging queries - http://ragnaar.com/projects/tb_loging.avi

Comment 9

8 years ago
Now I see it. Misunderstood steps to reproduce. Basically when you create new ldap address book using non ASCI symbols it won't work. It will not even try to connect to ldap server. Maybe something changed in LDAP sdk since TB 2.0.

Alexander no need to use external web servers you could attach all logs to this bug.
Component: Address Book → LDAP Integration
Keywords: regression
Product: Thunderbird → MailNews Core
QA Contact: address-book → ldap-integration
Version: 3.0 → 1.9.1 Branch
Those pref file segments Alexander attached make me extremely suspicious that this is a front-end bug.  Nominating for blocking, as I suspect this requires a re-spin...
Flags: blocking-thunderbird3- → blocking-thunderbird3?
It would be very interested to know when this regression crept in.  Anyone up for doing a binary search on the nightlies?
Keywords: regressionwindow-wanted
(Reporter)

Comment 12

8 years ago
Created attachment 415926 [details]
LDAP log

(In reply to comment #9)
> Alexander no need to use external web servers you could attach all logs to this
> bug.
Done.
(Reporter)

Comment 13

8 years ago
I wonder, is it regression from Bug 419595...

Comment 14

8 years ago
(In reply to comment #11)
> It would be very interested to know when this regression crept in.  Anyone up
> for doing a binary search on the nightlies?

Doing now, TB3 alpha 1 works, TB3 alpha 2 not works. Will come back with more results from nightly

Comment 15

8 years ago
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2008/07/2008-07-04-03-trunk/thunderbird-3.0a2pre.en-US.win32.installer.exe
Not working

http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2008/07/2008-07-02-05-trunk/thunderbird-3.0a2pre.en-US.win32.installer.exe
This one is working
Here's a bonsai link:

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fmail+mozilla%2Fmailnews&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-07-02+00%3A00%3A00&maxdate=2008-07-04+23%3A59%3A00&cvsroot=%2Fcvsroot

Comment 17

8 years ago
Miss one day build, 2008-07-03-03-trunk is first non-working build.

Here corrected one day bonsai link
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=mozilla%2Fmail+mozilla%2Fmailnews&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2008-07-02+00%3A00%3A00&maxdate=2008-07-03+23%3A59%3A00&cvsroot=%2Fcvsroot
(Assignee)

Comment 18

8 years ago
Not going to be blocking TB 3.0 on this, as we expect this is an infrequent action but we'll find a solution before 3.0.1.

I'm taking this bug as I'm fairly sure I know where the real bug lies, although I don't quite know what exposed it.
Assignee: nobody → bugzilla
blocking-thunderbird3.0: --- → .1+
Flags: blocking-thunderbird3? → blocking-thunderbird3-
Keywords: relnote

Updated

7 years ago
Keywords: regressionwindow-wanted
(Assignee)

Comment 19

7 years ago
Created attachment 420322 [details] [diff] [review]
The fix

I had to do a build in windows non-debug build to reproduce and fix this. The debug version gave assertions but ended up doing "the right thing" (typical windows debug builds :-( ).

I'd like a better test than checking the dirPrefId, but I think that actually requires doing a search to some extent. However I think the checks will be enough to make sure that we don't regress creation at least.
Attachment #420322 - Flags: superreview?(bienvenu)
Attachment #420322 - Flags: review?(bienvenu)

Comment 20

7 years ago
Comment on attachment 420322 [details] [diff] [review]
The fix

can you wrap this line:

+  var abUri = abManager.newAddressBook("\u041C\u0435\u043B\u0435\u043D\u043A\u0438", kLDAPTestSpec, kLDAPDirectory);

oh, and remove the extra space before the last )

IS_ALPHA(descr[srcIndex]) )
Attachment #420322 - Flags: superreview?(bienvenu)
Attachment #420322 - Flags: superreview+
Attachment #420322 - Flags: review?(bienvenu)
Attachment #420322 - Flags: review+
(Assignee)

Comment 21

7 years ago
Created attachment 420406 [details] [diff] [review]
The fix v2

This is what I actually checked in.
Attachment #420322 - Attachment is obsolete: true
Attachment #420406 - Flags: superreview+
Attachment #420406 - Flags: review+
Attachment #420406 - Flags: approval-thunderbird3.0.1?
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.1a1
(Assignee)

Comment 22

7 years ago
Comment on attachment 420406 [details] [diff] [review]
The fix v2

a=Standard8 (low-risk, contained patch also covered by unit tests).
Attachment #420406 - Flags: approval-thunderbird3.0.1? → approval-thunderbird3.0.1+
(Assignee)

Comment 23

7 years ago
Checked in: http://hg.mozilla.org/releases/comm-1.9.1/rev/35383a07b7fb
status-thunderbird3.0: --- → .1-fixed
Keywords: relnote
Nikolay can you verify this one with a 3.0.1 build and mark it Verified and add the verifed-thunderbird3.0 keywork please ?

Comment 25

7 years ago
Looks good
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20100111 Shredder/3.0.1pre
Status: RESOLVED → VERIFIED
Keywords: verified-thunderbird3.0

Updated

7 years ago
Keywords: fixed-seamonkey2.0.3
You need to log in before you can comment on or make changes to this bug.