Add extra "IT" lines for conditional code so xptcinvoke will compile on Thumb

RESOLVED DUPLICATE of bug 532198

Status

()

RESOLVED DUPLICATE of bug 532198
9 years ago
8 years ago

People

(Reporter: reed, Unassigned)

Tracking

Trunk
ARM
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 415475 [details] [diff] [review]
patch - v1

Upstreaming a patch from Kevin Welton <Kevin.Welton@arm.com> to add extra "IT" lines for conditional code so xptcinvoke will compile on Thumb. This comes from http://linux.onarm.com/bugzilla/show_bug.cgi?id=36.
Attachment #415475 - Flags: review?(timeless)
Attachment #415475 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #415475 - Flags: review?(vladimir)
Attachment #415475 - Flags: review?(timeless)
Attachment #415475 - Flags: review?(benjamin)
Comment on attachment 415475 [details] [diff] [review]
patch - v1

Looks fine, I'm surprised that this combines as-is into thumb instructions though.
Attachment #415475 - Flags: review?(vladimir) → review+

Comment 2

9 years ago
Comment on attachment 415475 [details] [diff] [review]
patch - v1

get someone to add /* comments */ explaining what the heck those two instructions do.
Attachment #415475 - Flags: review-

Comment 3

8 years ago
this url would have sufficed:
http://infocenter.arm.com/help/topic/com.arm.doc.dui0489b/Cjabicci.html

however the code in question is gone
Status: NEW → RESOLVED
Last Resolved: 8 years ago
OS: Linux → All
Resolution: --- → DUPLICATE
Duplicate of bug: 532198
You need to log in before you can comment on or make changes to this bug.