Closed Bug 532206 Opened 10 years ago Closed 10 years ago

Focus shows around plugins when you click on them

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

ARM
Maemo
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: dougt, Assigned: dougt)

References

Details

Attachments

(1 file)

a focus ring and yellow background is displayed around every plugin element when you click on them.
tracking-fennec: --- → ?
Attached patch patch v.1Splinter Review
the pres shell has a bunch of preferences that allows us to set up focus colorization.  The pref "browser.display.focus_ring_on_anything" is what we are using, but we don't really want to focus colorize embed elements.  So, instead of adding another confusing preference, i just removed the prefs that we set, and have moved the css into fennec's content.css file.  I think this allows us the maximum flexibility.
Assignee: nobody → mozbugz
Attachment #415548 - Flags: review?(mark.finkle)
Comment on attachment 415548 [details] [diff] [review]
patch v.1

>diff --git a/chrome/content/content.css b/chrome/content/content.css

>+/* make clicking on links stand out a bit */

  /* make clicking on links stand out a bit (bug 532206) */

let's add a reference back to this bug

>+html *:not(embed):focus, *:focus>font {

*:focus > font
(add spaces)

>+html *|*:link:focus, *|*:visited:focus {
>+  outline: 1px solid; -moz-mac-focusring !important;
>+  -moz-outline-radius: 3px; outline-offset: 1px;

    outline: 1px solid;
    -moz-mac-focusring !important;
    -moz-outline-radius: 3px;
    outline-offset: 1px;
(separate lines)

r+ with those nits fixed
Attachment #415548 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/159ee43b2d90
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 530837
verified FIXED on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre)
Gecko/20091202 Firefox/3.6b5pre Fennec/1.0b6pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre)
Gecko/20091202 Firefox/3.7a1pre Fennec/1.0b5
Status: RESOLVED → VERIFIED
It seems a little odd to me that this was fixed in the Fennec code.  It seems like we should be trying to make the platform diverge as little as possible between desktop and mobile, and thus fixing Web content issues in core code whenever possible.

It turns out that this is covering up a regression from Firefox 3.5 to 3.6 (bug 541406) that's bugging a lot of Web authors.
(In reply to comment #6)
> It seems a little odd to me that this was fixed in the Fennec code.  It seems
> like we should be trying to make the platform diverge as little as possible
> between desktop and mobile, and thus fixing Web content issues in core code
> whenever possible.

In this case, I don't think it was obvious that it was a problem with more than Fennec - we were setting focus_ring_on_anything and use_focus_colors, which are off by default, and I suppose we assumed that that was the cause of the problem.
Component: Linux/Maemo → General
OS: Linux → Linux (embedded)
QA Contact: maemo-linux → general
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.