IMAP: On Reply/ Forward as attachment compose window extra spaces are inserted into long subject field

VERIFIED DUPLICATE of bug 58114

Status

P3
normal
VERIFIED DUPLICATE of bug 58114
18 years ago
10 years ago

People

(Reporter: ji, Assigned: nhottanscp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
******observed with win32 2000091909 and linux 2000091906 build******

On the reply or forward as attachment compose window, extra spaces are inserted into the subject field if the subject is very 
long.

Steps to reproduce:
1. Have a mail with long non-ASCII  subject in you IMAP mailbox. 
    This problem doesn't happen if the mail is the POP/local folder.
    I'll attach a test mail folder later.
2. Select the mail and click on Reply or select Message | Forward as | Attachment

On reply/forward compose window, you'll see in the subject field, extra spaces are inserted. But after the mail is received, you 
won't see the extra spaces in the subject,
(Reporter)

Comment 1

18 years ago
Created attachment 15024 [details]
attached a screenshot
(Reporter)

Comment 2

18 years ago
Created attachment 15026 [details]
a mail folder containing a JPN mail with long subject. Please unzip it and copy the mail to IMAP.
(Assignee)

Comment 3

18 years ago
This is related to 38192, we resolve that by removing tabs before adding the 
subject string to thread pane. We can do the same here.
We eventually want to have better way of line unfolding code.
Status: NEW → ASSIGNED
OS: Windows 95 → All
Summary: On Reply/ Forward as attachment compose window extra spaces are inserted into long subject field → IMAP: On Reply/ Forward as attachment compose window extra spaces are inserted into long subject field

Comment 4

18 years ago
Is that related and in a way a dup of  38192?
(Assignee)

Comment 5

18 years ago
No, the problem source is the same but not a dup.
(Assignee)

Comment 6

18 years ago
*** Bug 58044 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: --- → M23
(Assignee)

Updated

18 years ago
Depends on: 58114
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 7

18 years ago
Marking as a dup of 58114.

*** This bug has been marked as a duplicate of 58114 ***

Comment 8

18 years ago
Verified as a duplicate of Bug 58114.
Status: RESOLVED → VERIFIED

Comment 9

18 years ago
*** Bug 64677 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.