Closed Bug 532418 Opened 10 years ago Closed 10 years ago

n900: Auto-capitalize feature is functional in the URLBar when Fennec is launched

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Maemo
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 533287

People

(Reporter: mfinkle, Assigned: mfinkle)

Details

Attachments

(1 obsolete file)

But if you close the awesomebar and reopen, the auto-cap feature is off - as it should be.

We might need to explicitly focus the textbox to get the IME code to kick in and turn the auto-cap feature off.
tracking-fennec: --- → ?
Attached patch patch (obsolete) — Splinter Review
Patch adds a .focus call before manually showing the autocomplete panel. The focus is enough for the IME to kick in and turn off the auto-capitalize feature.
Assignee: nobody → mark.finkle
Attachment #415809 - Flags: review?(gavin.sharp)
Attachment #415809 - Flags: review?(gavin.sharp) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/bb284fb246d0
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Post-B5
Summary: Auto-capitalize feature is functional in the URLBar when Fennec is launched → n900: Auto-capitalize feature is functional in the URLBar when Fennec is launched
verified FIXED On build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre) Gecko/20091204 Firefox/3.6b5pre Fennec/1.0b6pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?
that patch didn't end up working, so I backed it out:
https://hg.mozilla.org/mobile-browser/rev/eed69a83a41d
Status: VERIFIED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 533287
Target Milestone: Post-B5 → ---
Attachment #415809 - Attachment is obsolete: true
Ok, that resolution is fine with me and any new decision won't affect this bug anymore, so verified.
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.