Closed Bug 532540 Opened 10 years ago Closed 10 years ago

major update "billboard" needed for Firefox 3.6

Categories

(www.mozilla.org :: General, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: beltzner, Assigned: sgarrity)

References

()

Details

(Whiteboard: [1.9.2-fixed])

When we release Firefox 3.6 we plan on making a MCFUMU (Manual Check for Unprompted Major Update) available, as we did with Firefox 3.5, in order to promote the update.

We need "billboards", as we had for Firefox 3.5: http://www.mozilla.com/en-US/firefox/3.5/details/
Flags: blocking-firefox3.6+
Assigning this one to me - Laura and I will figure this out.

What's the deadline? (I'm sure it's soon, but if there's a specific date I should know about that would help me prioritize)
Assignee: nobody → jslater
I'm thinking no graphical changes, just text, and if we could have it by Dec 10 that would be best; I thought we were already tracking this, my fault for not filing sooner.
We have a copy of the 3.5 version of this page setup in the 3.6 branch in SVN:

http://www-3.6.stage.mozilla.com/en-US/firefox/3.6/details/

I can make changes when text (and/or any visual updates) are ready.
Here is the revised copy. Please comment if you see any issues. Steven, if there have been no comments by 10 am PST can you go ahead and implement?

Thanks!

 Title: Firefox 3.6 is Here!

 Subtitle: Get the World's Best Browser (link, same as old promo)

-Over 35,000 themes for your Firefox. 
-Plugin check & other new security tools.
-Improved stability and performance.
(In reply to comment #4)
> Here is the revised copy. Please comment if you see any issues. Steven, if
> there have been no comments by 10 am PST can you go ahead and implement?

I've got this implemented in the 3.6 branch in r57490 (see the link in comment #3). Let me know if there are any changes.
Thanks Steven. 

Anyway we can fit the headline on to one line? Maybe make the font a touch smaller?

Also, the first bullet should probably also fit on one line. It looks like there's enough room, but let me know if there isn't. I can re-do the text if needed.
Laura, I've cleaned up the spacing/padding a bit in r57551.
I think it looks great!  marking Fixed.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Does this need to be tested by the QAE team?
im assuming so...
Assignee: jslater → mozwebqa
(In reply to comment #10)
> im assuming so...

QAE != webQA.
Assignee: mozwebqa → steven
I've compared http://www-3.6.stage.mozilla.com/en-US/firefox/3.6/details/ with http://www.mozilla.com/en-US/firefox/3.5/details/; looks good to me.  Haven't heard back from the QAE team, so verifying from my side.
Status: RESOLVED → VERIFIED
Whiteboard: [1.9.2-fixed]
Hey guys. Per some recent conversations with the product team, we'd like to make a slight copy change to this text to reflect Kovash's recent findings about why people decline the updates (http://blog.mozilla.com/metrics/2010/01/28/why-people-dont-upgrade-their-browser-part-iii/).

Bottom line is that we want to make the "free" concept clearer. The only text we're adding is "Free Upgrade:", but the full thing is below. I know this will push the subhead onto two lines (even in en-US) but it looks like there's room with maybe a bit of visual tweaking.

Also, apologies for the extra l10n impact here. Seth is aware of this, so hopefully we can figure out a way to make it manageable.


Title: Firefox 3.6 is Here!

Subtitle: Free Upgrade: Get the World's Best Browser

-Over 35,000 themes for your Firefox.
-Plugin check & other new security tools.
-Improved stability and performance.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
I've added the "Free Upgrade:" text in trunk (r61694). There is room in there for it without altering the layout:

http://www-trunk.stage.mozilla.com/en-US/firefox/3.6/details/

This might end up wrapping to three lines in some locales. The layout expands gracefully, but it would trigger a vertical scrollbar.
Now it will look as if Firefox upgrades are not always free by putting "Free Upgrade:"
These changes have a major l10n impact and we already have another new major update box being prepared in bug 542589

The basis for this change is a survey run only on English users. So before any l10n action my questions would be:

- Are there per locale metrics showing that non-English users do not upgrade like en-US users?
- What is the deadline to have this done for all locales?

Note that "free upgrade" is going to be tricky to translate and keep it short in many locales, so expect a vertical scrollbar for almost all locales.
(In reply to comment #16)
> These changes have a major l10n impact and we already have another new major
> update box being prepared in bug 542589
Understood. Seth, what do you think?

> - Are there per locale metrics showing that non-English users do not upgrade
> like en-US users?
Copying Kovash on this bug...Ken, can you weigh in on this?

> - What is the deadline to have this done for all locales?
Not sure...can someone from the Firefox or RelEng teams comment on that?(In reply to comment #16)
> > - What is the deadline to have this done for all locales?
> Not sure...can someone from the Firefox or RelEng teams comment on that?(In
> reply to comment #16)

From a RelEng point of view the details URL always points to the same (locale specific) place, so it's up to you how you want to manage changes to the website. Pushing billboards in small batches would be one strategy, although that might make it more involved to try to quantify the effect of the change.
> - Are there per locale metrics showing that non-English users do not upgrade
> like en-US users?

There are different ways to approach this question, and I'm not sure what specific metrics might inform our decision making.  If we want to know how user interaction with the /details page (billboard) differs by locale, we don't have any numbers or insights around that.
(In reply to comment #16)
> The basis for this change is a survey run only on English users. So before any
> l10n action my questions would be:
> 
> - Are there per locale metrics showing that non-English users do not upgrade
> like en-US users?
> - What is the deadline to have this done for all locales?

I don't think there's a deadline, it's just something we think will goose the upgrade numbers. My feeling is that we should make this bug about the en-US change and then allow Pascal to track the l10n changes separately; we can change the billboards as they come in.

> Note that "free upgrade" is going to be tricky to translate and keep it short
> in many locales, so expect a vertical scrollbar for almost all locales.

Maybe drop the "Get the World's Best Browser" out of the subhead in that case, replacing it entirely with "Free Upgrade"?
+1 for Mike's notes in comment #20. Although, to be clear, I think the text from comment #13 should be used in en-US even if we have to edit the localized versions.
Duplicate of this bug: 495178
(In reply to comment #23)
> So, is what I have in trunk ok then?
> http://www-trunk.stage.mozilla.com/en-US/firefox/3.6/details/

For en-US, yes. My understanding is that locales should have the option of tweaking the subhead as described in comment #20.
Ok, that is merged from trunk to stage in r62190. One file to push to production: en-US/firefox/3.6/details/index.html
No longer blocks: 545789
(In reply to comment #26)
> Whats left to do here?

Just pushing the file from stage to production.
I can push files.  Does this need to be coordinated with anything else, or should I push them now?
Can I get a list of which files we're talking about here? It's meandered a bit in the bug.

If we're just talking about http://www.mozilla.com/en-US/firefox/3.6/details/ then there's nothing to co-ordinate, push away!

Pascal, AIUI, you guys will be translating this on an ongoing basis, yeah?
yes, we'll keep translating the major update billboards with the web localizers.
(In reply to comment #29)
> Can I get a list of which files we're talking about here? It's meandered a bit
> in the bug.

Just two files:
firefox3.6/style/firefox/3.6/details.css
en-US/firefox/3.6/details/index.html
Sorry I missed the bugmail on this.

The CSS file seems to have already made it to production, not sure when. I pushed the HTML file just now. Marking FIXED, please re-open if that's wrong.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.