Session cookie lost when launching openvpn-als/adito java agent

RESOLVED DUPLICATE of bug 526462

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 526462
9 years ago
8 years ago

People

(Reporter: Cyril Pawelko, Unassigned)

Tracking

3.6 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

236.16 KB, application/octet-stream
Details
(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; fr; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4 (.NET CLR 3.5.30729)

Using french firefox 3.6b3/4 on french Windows Seven/XP, OpenVPN ALS (formely adito) "agent" loads and fails because the session cookie (JESSIONID) is being deleted by firefox when the applet is launched.
Same behavior on Windows XP with firefox 3.6b4
Java version 6.0.170.4
The same version works wells with firefox 3.5 and IE8

This bug exists with old releases of adito 0.9.1 and recent developpement builds.

Reproducible: Always

Steps to Reproduce:
1. Install Adito 0.9.1 (or more recent OpenVPN ALS version) from http://sourceforge.net/projects/openvpn-als/
2. Log in as administrator
3. Click "Launch Adito Agent"
Actual Results:  
Java Agent starts and displays "Error: No session"
In firebug : The JESSIONID cookie value changes when the agent is launching

Expected Results:  
Java agent should start and communicate with adito server.
In firebug : The JESSIONID cookie value remains the same

Adito/OpenVPN-ALS is a Web/Java based SSL VPN Server, released under GPL.
I didn't contact developpers since this bug appeared only with firefox betas.
Not tested under Linux.
I couldn't find hosted adito demos. I could eventually configure one for testing purposes.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch
(Reporter)

Comment 1

9 years ago
Created attachment 415958 [details]
Wireshark capture

Partial capture showing behavior with firefox.
Starting at packet 39, "JSESSIONID=172qyp95v7lfs" is no more sent.
(Reporter)

Comment 2

8 years ago
It works with firefox 3.6 beta 5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 526462
You need to log in before you can comment on or make changes to this bug.