Closed Bug 533216 Opened 10 years ago Closed 10 years ago

Server not found

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 475603

People

(Reporter: tcole1983, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

Server not found

      

      
      
      

      
        
        

          

Firefox can't find the server at mail.google.com.

        


        
        


    *   Check the address for typing errors such as
          ww.example.com instead of
          www.example.com

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.


Once I hit try again the page loads fine.  Pages load fine with IE8 and Chrome.  I notice it most when I try to go to gmail, but it happens frequently with any other webpage also.  It always happens when I first start up my computer and then go from google homepage to gmail by the link.  Once I go there and hit the try again page and it loads fine then it will allow me to go back without problems.  Closing the browser and then trying again then it is hit or miss if it happens again. 

Reproducible: Sometimes

Steps to Reproduce:
1.Go to gmail from google homepage
2.
3.
Actual Results:  
100% of the time after I have first started my computer I get a server not found error.  About 20% of the time after that I get a sever not found error.  Other pages are about 10% of the time server not found error.

Expected Results:  
If I hit try again the page always loads fine.

Loaded the page right the first time.
If you start a command prompt and enter ping mail.google.com when you are experiencing the issue what are your results? (checking for dns server issues)

If you start FF in safe mode do you still experience the issue? http://support.mozilla.com/en-US/kb/Safe+Mode
Which router are you using ?

Please open about:config, confirm the warning, right click on the list and select NEW, Boolean, for preference name use "network.dns.disablePrefetch" (without the "") and the Value is "true".
Restart Firefox - is it now better ?
(In reply to comment #1)
> If you start a command prompt and enter ping mail.google.com when you are
> experiencing the issue what are your results? (checking for dns server issues)
> 
> If you start FF in safe mode do you still experience the issue?
> http://support.mozilla.com/en-US/kb/Safe+Mode

When I pinged the page it sent and received the 4 packets with no losses.
(In reply to comment #2)
> Which router are you using ?
> 
> Please open about:config, confirm the warning, right click on the list and
> select NEW, Boolean, for preference name use "network.dns.disablePrefetch"
> (without the "") and the Value is "true".
> Restart Firefox - is it now better ?

This seems to have cleared up the gmail issue at least.  I haven't had a chance to try other pages, but I will report back after a couple days of surfing.  Also I have a 2wire 3800HGV-B home gateway from At&t.
<note>I recently moved to AT&T Uverse and have found their DNS servers [68.94.156.1/68.94.157.1] to be subpar (a lot of page not founds that would work with a refresh). I changed to Open DNS and haven't had an issue since. http://www.opendns.com/</note>
This seems to be a bug in the router which is known for a few different types of routers.
Gecko is using DNS prefetching, it resolves host that it finds in an html page during the loading of the page and before you click on the links. This generates many DNS requests in a short time after you loaded a html page with links and some routers have a bug that generates DNS failure responses.

There are 3 ways to "fix" it :
a) disable the DNS prefetch in FF and you will get such errors from the router less frequently but it can still happen.
b) do not use the dns server/forwarder in the router. Just add a fixed DNS server ion the windows TCP/IP settings
c) get a router without bug.

I will mark this bug invalid if disabling the DNS prefetch helps to "fix" your issue.
(In reply to comment #4)
> (In reply to comment #2)
> > Which router are you using ?
> > 
> > Please open about:config, confirm the warning, right click on the list and
> > select NEW, Boolean, for preference name use "network.dns.disablePrefetch"
> > (without the "") and the Value is "true".
> > Restart Firefox - is it now better ?
> 
> This seems to have cleared up the gmail issue at least.  I haven't had a chance
> to try other pages, but I will report back after a couple days of surfing. 
> Also I have a 2wire 3800HGV-B home gateway from At&t.


This fix seems to be causing my router/gateway to crash.  Going to try disabling the DNS prefetch in FF.  Only question is why does it work with other browsers fine and not FF?  Doesn't seem like that would be a router problem then.
(In reply to comment #7)
> (In reply to comment #4)
> > (In reply to comment #2)
> > > Which router are you using ?
> > > 
> > > Please open about:config, confirm the warning, right click on the list and
> > > select NEW, Boolean, for preference name use "network.dns.disablePrefetch"
> > > (without the "") and the Value is "true".
> > > Restart Firefox - is it now better ?
> > 
> > This seems to have cleared up the gmail issue at least.  I haven't had a chance
> > to try other pages, but I will report back after a couple days of surfing. 
> > Also I have a 2wire 3800HGV-B home gateway from At&t.
> 
> 
> This fix seems to be causing my router/gateway to crash.  Going to try
> disabling the DNS prefetch in FF.  Only question is why does it work with other
> browsers fine and not FF?  Doesn't seem like that would be a router problem
> then.

"Going to try disabling the DNS prefetch in FF."

Guess I already did that huh?  Any more suggestions?  Changing router is not an option...it is integrated with our tv box and when it isn't on our TV doesn't work.
How should this be a software problem if the router crashes ?
That is always the fault of the router.

Firefox asks the OS (windows) for a DNS resolution and not the router.
Windows itself asks the routers DNS server if it can not answer the name request from Firefox.

I would suggest that you configure windows to use a different fixed DNS server and not the routers DNS server.

You can use for example Googles new public DNS server:
http://code.google.com/speed/public-dns/
Follow the "configuration instructions" link if you don't know how to use fixed DNS servers in windows.
Duplicate of this bug: 533340
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475603
(In reply to comment #9)
> How should this be a software problem if the router crashes ?
> That is always the fault of the router.
> 
> Firefox asks the OS (windows) for a DNS resolution and not the router.
> Windows itself asks the routers DNS server if it can not answer the name
> request from Firefox.
> 
> I would suggest that you configure windows to use a different fixed DNS server
> and not the routers DNS server.
> 
> You can use for example Googles new public DNS server:
> http://code.google.com/speed/public-dns/
> Follow the "configuration instructions" link if you don't know how to use fixed
> DNS servers in windows.

I guess what I don't understand is why the older versions of firefox worked fine, why I can hit refresh and the pages load fine, and why the other two browsers I have work fine and it be said to be a router error...
>I guess what I don't understand is why the older versions of firefox worked
>fine, 
because DNS prefetching is a nwe feature ?

>why I can hit refresh and the pages load fine,
you have to ask the router vendor why the router fails under such conditions if disabling DNS prefetching or using another DNS server (not the router) helps.

>and why the other two browsers I have work fine 
because they spread their dns requests over the time / don't do DNS prefetch

>and it be said to be a router error...
How can it be not a router error with such symptoms ?
You need to log in before you can comment on or make changes to this bug.