Closed Bug 533329 Opened 11 years ago Closed 11 years ago

[Mozmill] Verify that Calendar is working properly with UTF-8 characters

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: merike, Assigned: merike)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; et; rv:1.9.2b4) Gecko/20091124 Firefox/3.6b4
Build Identifier: 

As most of the event fields are limited to predefined values I believe this only affects title, location, description and category fields. Also trying with calendar name. Should it also test attachment url for IDN? Not sure which is the correct way for these to be handled with.

Reproducible: Always
Attached patch UTF-8 test v1Splinter Review
Note, this doesn't run as it is. This is due to bug 506760. If test string is set to "abcd" then it runs correct so I'd blame it all on Mozmill.
Attachment #416452 - Flags: review?(ctalbert)
Component: Mozmill → General
Product: Testing → Calendar
Merike, have you ever tried to run Mozmill tests from the command line? It should help until the bug is fixed in the IDE.
Assignee: nobody → gasell+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
QA Contact: mozmill → general
Ok, as bug 506760 shows it's not only an issue with the IDE. If this is only a bug for handling UTF-8 from the command line we should dupe it against bug 506760.
It is not. It is to implement a Mozmill test that would verify that Calendar handles UTF-8 characters properly. The fact that it was initially filed under Mozmill component was a mistake on my part.
Thanks. Updating summary accordingly to reduce confusion. This depends on bug 506760.
Depends on: 506760
Summary: [Mozmill] UTF-8 test → [Mozmill] Verify that Calendar is working properly with UTF-8 characters
Comment on attachment 416452 [details] [diff] [review]
UTF-8 test v1

This test looks good.  We can go ahead and check it in with a comment about the bug it depends on.  Want me to add that comment and check it in?
Attachment #416452 - Flags: review?(ctalbert) → review+
Sure, I don't see why not.
Checked in to comm-central as changeset f165003913de

--> FIXED
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.