Move "Open Link in New Tab" context menu above "Open Link in New Window"

RESOLVED DUPLICATE of bug 322736

Status

()

enhancement
RESOLVED DUPLICATE of bug 322736
10 years ago
10 years ago

People

(Reporter: kengggg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

10 years ago
I've write a proposal [1] for improving context menu for tabbed browsing UX by moving "Open Link in New Tab" context menu above "Open Link in New Window".

Since tabbed browsing is a standard feature for current generation of web browser; User experience and expectation nowadays are based on tab. Therefore, context menu "Open Link in New Tab" should be above to "Open Link in New Window"

Google Chrome is also using this approach, too.

Attached image for illustrating my idea.

[1] : http://keng.ws/991/firfox-ux-proposal-open-link-in-new-tab/

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322736
You need to log in before you can comment on or make changes to this bug.