Closed Bug 533654 Opened 10 years ago Closed 8 years ago

Dismissing a recurring event fails with MODIFICATION_FAILED

Categories

(Calendar :: Provider: GData, defect, major)

x86
Linux
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: avi-j, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.15) Gecko/2009102815 Ubuntu/9.04 (jaunty) Firefox/3.0.15
Build Identifier: 20090817

I have experienced the following issue, which has been replicated by other users. (I am using another user's description of the issue, since his logs are more complete than mine.)

When I try to dismiss an event, I get an error box:
Title: An error has occurred
Msg: An error occurred when writing to the calendar Google Calendar!
Details Error number: MODIFICATION_FAILED
Description: <none>

I turned on debugging to try and see what the error is.  It seems that
Google is expecting a little more information in the requests that
Thunderbird is sending, from the log console:

"A request Error Occurred. Status Code: 400 Bad Request Body: [Line
18, Column 13, element gd:when] Missing attribute:
&#39;startTime&#39;"

Could this be a bug with the add-on?  It use to work just fine, but
now all events get this problem  I;ve tired removing the add-ons and
reinstalling, but it doesn't seem to make a difference.

Any idea's?

Thunderbird 2.0.0.23
Lightning 0.9
Provider for Google Calendar 0.5.5

Here is the relevant info from the logs, i removed my personal info in
it, you can see the request and see that the "startTime" attribute is
missing

****************************

Modifying item Nick's B-Day

Logging object...
action: Setting Upload Data:
content: application/atom+xml; charset=UTF-8
data: <entry xmlns:gd="http://schemas.google.com/g/2005"
xmlns:gCal="http://schemas.google.com/gCal/2005" xmlns="http://
www.w3.org/2005/Atom">
  <category scheme="http://schemas.google.com/g/2005#kind"
term="http://schemas.google.com/g/2005#event"/>
  <title type="text">Nick's B-Day</title>
  <content type="text"/>
  <author>
    <name> --REMOVED-- </name>
    <email> --REMOVED-- </email>
  </author>
  <gd:transparency value="http://schemas.google.com/g/
2005#event.opaque"/>
  <gd:eventStatus value="http://schemas.google.com/g/
2005#event.tentative"/>
  <gd:where valueString=""/>
  <gd:who email="--REMOVE...@gmail.com" rel="http://schemas.google.com/
g/2005#event.organizer" valueString="--REMOVED--"/>
  <gCal:sendEventNotifications value="true"/>
  <gd:reminder minutes="2880" method="alert"/>
  <gd:when>
    <gd:reminder minutes="2880" method="sms" xmlns:openSearch="http://
a9.com/-/spec/opensearchrss/1.0/" xmlns:gml="http://www.opengis.net/
gml" xmlns:georss="http://www.georss.org/georss" xmlns:batch="http://
schemas.google.com/gdata/batch"/>
    <gd:reminder minutes="2880" method="email"
xmlns:openSearch="http://a9.com/-/spec/opensearchrss/1.0/"
xmlns:gml="http://www.opengis.net/gml" xmlns:georss="http://
www.georss.org/georss" xmlns:batch="http://schemas.google.com/gdata/
batch"/>
  </gd:when>
  <gd:extendedProperty name="X-MOZ-LASTACK"
value="2009-11-19T16:57:53Z"/>
  <gd:extendedProperty name="X-GOOGLE-SNOOZE-RECUR"
value="({'1258693200000000':&quot;20091119T170253Z&quot;})"/>
  <gd:visibility value="http://schemas.google.com/g/
2005#event.default"/>
  <gd:recurrence>DTSTART;TZID=floating:20061120
DTEND;TZID=floating:20061121
RRULE:FREQ=YEARLY;INTERVAL=1;WKST=SU</gd:recurrence>
  <gCal:sequence value="1"/>
  <gCal:uid value="9o63j--REMOVED--j0u77je0"/>
</entry>
End object

calGoogleRequest: Requesting PUT
http://www.google.com/calendar/feeds/--REMOVED--/private/full/9o63j--...

General response failed: [Exception... "A request Error Occurred.
Status Code: 400 Bad Request Body: [Line 18, Column 13, element
gd:when] Missing attribute: &#39;startTime&#39;"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
file:///C:/Documents%20and%20Settings/Mike/Application%20Data/Thunderbird/Profiles/bloql3c6.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/components/calGoogleCalendarModule.js
->
file:///C:/Documents%20and%20Settings/Mike/Application%20Data/Thunderbird/Profiles/bloql3c6.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleCalendar.js
:: cGC_general_response :: line 970"  data: no] 

PLEASE NOTE THE FOLLOWING IMPORTANT INFORMATION:

With provider 0.5.2 it works correct. With provider
0.5.3, 0.5.4 and 0.5.5 it gives the error.

When I downgraded the plugin from 0.5.5 to 0.5.2 the error no longer occurred.

Reproducible: Always

Steps to Reproduce:
1. Reminder pops up for recurring event
2. Click "Dismiss"
3.
Actual Results:  
Title: An error has occurred
Msg: An error occurred when writing to the calendar Google Calendar!
Details Error number: MODIFICATION_FAILED
Description: <none>

Expected Results:  
Instance of recurring event should dismiss from Google calendar.
OK, I was seeing this with 0.5.5, and downgrading to 0.5.2 solved it for me as well.  I thought the problem had gone away [for me] when I tried to recreate the issue with 0.5.6 and was unable to.  I did just get it on 0.5.6, though.  However, I'm only getting a basic 400 Bad Request and no other diagnostics.

I logged the txn with Wireshark, getting the post data for both a failed dismiss (0.5.6) and an OK one (0.5.2).  I have the full HTTP POST headers if you need them, but under the presumption that it's the XML that's at fault, I'll attach those.
Edited a bit for privacy.
Edited a bit for privacy.
Neil, does this still happen with the latest 1.0b2pre and Provider 0.6b1 nightlies?
This bug's should definitely be marked as 'CONFIRMED'.

The problem has been happening with Sunbird ever since I began downloading the nightly builds of sunbird 1.0 a couple of months ago, up to my present Version 1.0b2pre.  (I have an HP desktop running Windows 7 32-bit).   I have just this morning tried dismissing about four alarms at once (for medicines over the last couple of days, during which I did not start Sunbird) and I got the usual error message:
- - - - - - - - 
An error occurred when writing to the calendar Medicine!
Error code: MODIFICATION FAILED
Description: <This is blank>
- - - - - - - - 
The 'Medicine' calendar on the left-hand panel then has a yellow triangle with exclamation mark, presumably signalling that there has been an error.

When I then close and restart Sunbird, no task window appears, so the tasks must have been dismissed, despite the error message.  The 'Medicine' calendar, however, is locked to 'Read only', which it was not before.

When I un-read-only the 'Medicine' calendar, then close and restart Sunbird again, no task window appears and all seems normal.

This behaviour has been constant ever since I began downloading the Sunbird 1.0 builds a couple of months ago.  I have five calendars, all .ics.  Three are locked to read-only on my computer (my wife modifies them on her computer, and they are copied daily to mine).  The other two are not read only, of which the second 'Medicine' calendar consists only of tasks. 

Could I make a plea for retaining Sunbird as a stand-alone calendar.  I use The Bat! for email, and I don't want to run Thunderbird just to get the Lightning add-on.  But I really do want the excellent Sunbird calendar.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've not seen this go wrong recently, I think since upgrading to TB3, and I have had to dismiss recurring events.

I have TB3, Lightning 1.0b1 and Provider... 0.6b1.
This bug is a complete show-stopper for me.  I use TB3, Lightning 1.0b1 and provider 0.6b1.  Events pop up as alarms which I cannot dismiss, and if I close the window (the only way to get rid of the alarm window), it pops up again about 10-15 minutes later.  So while Thunderbird is running, I get a pointless window popping up every fifteen minutes, which is obviously very irritating.  I think this happens when I move one in a series of recurring events, but I definitely do see it with the latest version of all software.
Just for info., I did see this on a number of events in quick succession yesterday, will all the latest versions, but it seems to have only happened once without repeating the same entries, so it could have been network issues.
Could you export this event to ICS and attach it to this bug? This might help me reproduce the bug.
Here's an event that keeps popping up from my Google calendar.  It was due to happen a bit over a week ago but I haven't managed to dismiss it yet.  This event is a recurring event due to happen at 2pm on Tuesday, but that week I moved it (via the Google calendar interface) to 3pm Wednesday.  I haven't dismissed it yet -- but I did successfully dismiss the notification about the same meeting the following Tuesday.  Here's what I think is the pertinent bit of the ICS file, with a couple of details snipped:

BEGIN:VEVENT

CREATED:00011230T235800Z

LAST-MODIFIED;TZID=Europe/London:20100517T093231

UID:v9m0q1nbkaaf5p5fscrc0e6bvg

SUMMARY:CRG meeting

STATUS:CONFIRMED

RECURRENCE-ID;TZID=Europe/London:20100504T140000

ORGANIZER;RSVP=FALSE;CN=Neil Brown;CUTYPE=INDIVIDUAL:mailto:<snip>

X-MOZ-LASTACK:20100429T092128Z

DTSTART;TZID=Europe/London:20100505T150000

DTEND;TZID=Europe/London:20100505T160000

SEQUENCE:5

X-GOOGLE-EDITURL:https://www.google.com/calendar/feeds/<snip>/private/full/v9m0q1nbkaaf5p5fscrc0e6bvg_20100504T130000Z/634097683

 51

URL:https://www.google.com/calendar/event?eid=<snip>

TRANSP:OPAQUE

CLASS:DEFAULT

BEGIN:VALARM

ACTION:DISPLAY

TRIGGER;VALUE=DURATION:-PT10M

DESCRIPTION:Default Mozilla Description

END:VALARM

END:VEVENT
I am also experiencing this MODIFICATION_FAILED error, though only on events that have an attendee. I've attached the output (MODIFICATION_FAILED_log.txt) from a successful dismissal, a dismissal which pops back up, and a dismissal which then generates the MODIFICATION_FAILED error before popping back up. 

The successful dismissal occurred with an event that had no attendees.

I am using:
Thunderbird 3.1.8
Lightning 1.0b2
Zimbra 7.0.1
Calendars from Google work flawlessly one minute then they alternately stop working. Dismissing events causes errors on one calendar but not others. Too random to pinpoint and annoying enough to be a deal breaker for TB, Lightning and provider. I  have one computer that works with 3 calendars and one computer that can't get past two working. April 4, 2011 TB3.1, latest Lightning and provider.
the problem is now worst than ever, I cant dismiss any of my recurring event the first time, it does a MODIFICATION_FAILED and change the calendar to read only. I've got to remove the read only state each time and try dismissing the event a few time before being succefull. The same occur when reporting the alarm or simply closing the reminder windows. My calendar are local ics file, I'm on linux x86_64 with thunderbird 8 lighting 1.0
I'm seeing this go doolally since I got TB8 (Lightning version?), although I don't see the MOD_FAILED error;  alarms just refuse to go away once actioned via a button (e.g., snooze).  Closing the dialogue then gives an error along the line of "it's been updated on the server do I want to overwrite or reload" (although that might also happen if I leave it long enough when trying to snooze as well).

No such problems on a TB6 with Lightning 1.0b5 which hasn't been updated yet.
thinking about comment 15 I found out that if eg. I dismiss an event which doesn't disapear and then go in calendar bar (on left, sorry about the translation my installation is in french) and then do a right click -> refresh distant calendar the problematic event disappear from the reminder windows and seam to really be dismissed. The same occur with a snooze. I haven't tested with a distant calendar, mine is a local ics file.
I'm also getting this error a lot lately.  Originally when importing the Sunbird events into Lightning I didn't realise it was working so got everything imported three times, but now even exporting my calendar to an .ics then importing it into a different calendar gives me the same terse error in the new calendar.

Is there any way to get some debugging information or something more helpful than just MODIFICATION_FAILED?
Adam, you'll likely want to enable logging, and then you may view the transactions in the Error Console. To enable logging, you'll need to (possibly) create the prefs calendar.debug.log and calendar.debug.log.verbose, and then toggle at least the first to true (the second will, obviously, give you more detail).

Then, open up the Error console and have a look.

HTH
Thanks for the info - had to wait another month for the event to recur, and these three errors come up when I try to snooze it for some amount of time:

Warning: There has been an error reading data for calendar: Home2.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80004005. Description: generation too old for for modifyItem

Error: An error occurred when writing to the calendar Home2! Error code: MODIFICATION_FAILED. Description: 
Source File: resource://calendar/modules/calUtils.jsm -> file:///home/adam/.thunderbird/adam.profile/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Line: 1101

Warning: Use of getAttributeNode() is deprecated. Use getAttribute() instead.
Source File: chrome://calendar/content/calendar-error-prompt.xul
Line: 0

Does this shed any light on what the issue might be?
@Adam Nielsen - Does this error still occur with Lightning version 1.2.1? If so, can you provide more information on the event(s) that trigger the error - including the Repeat setting, the number of reminders on the event, and the amount of time before the event that the reminder(s) are set for?
Apologies for the delay, had to wait another month :-$  The same appointment came back, and this time with Lightning 1.2.1 I could snooze it and dismiss it without any problems!  So for me at least, this bug has been fixed.  Thanks to whoever it was that got it fixed :-)
What about the others? Does this also work now with the latest versions?
I've not seen this in a while either.
confirm, didn't have the for a while and I still abusively use recurring event in all possible way. I think it can be set as solved, thanks
I haven't seen it for a while either, and I think I was the first to complain. :) It's solved from my perspective. Thanks, everyone.
Thank you for your feedback. Resolving as WORKSFORME per previous comments.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → 1.2.1
Sorry for writing in this bug, but today I updated the TB to version 15 and Lighting to 1,7 and I receive this error (when working with my google calendar). Any ideas how to proceed?
(In reply to milen_83bg from comment #27)
> Sorry for writing in this bug, but today I updated the TB to version 15 and
> Lighting to 1,7 and I receive this error (when working with my google
> calendar). Any ideas how to proceed?

This is not a support forum. You will want to find one (such as stackoverflow.com) and post your question there.
You need to log in before you can comment on or make changes to this bug.