Make LDAP requests asynchronous so it not block UI

RESOLVED DUPLICATE of bug 79509

Status

MailNews Core
LDAP Integration
--
enhancement
RESOLVED DUPLICATE of bug 79509
8 years ago
5 years ago

People

(Reporter: Nikolay Shopik, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Currently any slow LDAP server will cause TB to hang for moment. LDAP thread should be asynchronous and not block UI.

Comment 1

8 years ago
Just to expand upon that, here's my experience:

I access a slow Exchange server's LDAP dir over VPN, so LDAP response time is quite slow. Every address I type in the address bar of a compose window (indeed, almost every character I type for the address) causes a complete hang of the TB UI... *and* all of GNOME. It appears the LDAP lookup is blocking the GNOME UI thread. Once LDAP replies (perhaps 20s later), the address completion list displays, and selecting an address from the list is fast.

The problem affects both TB2 and TB3. UI is completely unresponsive. In Ubuntu, the TB window is grayed out for failure to respond.
(Reporter)

Updated

7 years ago
Blocks: 373167

Comment 2

7 years ago
xref Bug 79509 - avoid stalling out if ldap C SDK hangs during connect() - which has a draft patch
Keywords: perf
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 79509
(Reporter)

Updated

7 years ago
No longer blocks: 373167
You need to log in before you can comment on or make changes to this bug.