Firefox hash algorithm allows trivial collisions

RESOLVED DUPLICATE of bug 290032

Status

()

RESOLVED DUPLICATE of bug 290032
9 years ago
9 years ago

People

(Reporter: skonstantinov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 (.NET CLR 3.5.30729)

http://mxr.mozilla.org/mozilla/source/netwerk/cache/src/nsDiskCacheDevice.cpp#240
hash function allows trivial collisions, for example:

http://vec02.maps.yandex.ru/tiles?l=map&v=2.10.2&x=618&y=321&z=10
and
http://vec01.maps.yandex.ru/tiles?l=map&v=2.10.2&x=618&y=322&z=10
have identical hash.

This problem could be easily fixed using 3, 5, 7 or any other odd shift in the rotate function.

Reproducible: Always
(Reporter)

Updated

9 years ago
Summary: Firefox hashy algorithm allows trivial collisions → Firefox hash algorithm allows trivial collisions

Comment 1

9 years ago
See bug 290032 for further discussion.
Component: General → Networking: Cache
Product: Firefox → Core
QA Contact: general → networking.cache
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 290032
You need to log in before you can comment on or make changes to this bug.