gdata-provider.xpi should support SeaMonkey 2

RESOLVED FIXED in 1.0b1

Status

Calendar
Provider: GData
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: tonymec, Assigned: Fallen)

Tracking

({verified1.9.1})

Trunk
1.0b1
verified1.9.1

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

Now that Lightning comm-1.9.1 builds support (among others) SeaMonkey 2 (minVersion = 2.0b2, maxVersion = 2.0.2pre), the gdata-provider.xpi builds found in the same FTP directories as these lightning.xpi builds should support the same applications.

I could install gdata-provider.xpi 0.6pre together with Lightning 1.0b2pre in:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7pre) Gecko/20091209 Lightning/1.0b2pre SeaMonkey/2.0.2pre
- Build ID: 20091209000712

but for gdata-provider (not for Lightning) I had to override the version compatibility, and the addons manager says it is "Not compatible with SeaMonkey 2.0.2pre".
P.S. The actual Lightning and gdata-provider builds I installed were the tinderbox-builds dated 2009-12-09 09:27 UTC, from ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-1.9.1/linux-xpi-linux/1260353473/
Assignee: nobody → mschroeder
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86 → All
Created attachment 416914 [details] [diff] [review]
Patch for comm-central
Attachment #416914 - Flags: review?(philipp)
Created attachment 416915 [details] [diff] [review]
Patch for comm-1.9.1
Attachment #416915 - Flags: review?(philipp)
(Assignee)

Comment 4

9 years ago
Comment on attachment 416914 [details] [diff] [review]
Patch for comm-central

We don't have SEAMONKEY_VERSION defined in the makefile. I'll upload patches that fix the issue in a moment.
Attachment #416914 - Flags: review?(philipp) → review-
(Assignee)

Updated

9 years ago
Attachment #416915 - Flags: review?(philipp) → review-
(Assignee)

Comment 5

9 years ago
Created attachment 416967 [details] [diff] [review]
Patch for comm-central - v2

I'm also bumping the gdata version to 0.7pre for trunk
Assignee: mschroeder → philipp
Attachment #416914 - Attachment is obsolete: true
Attachment #416967 - Flags: review+
(Assignee)

Comment 6

9 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/9cd357660da2>


-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Comment 7

9 years ago
Sorry about this, but the checkins on 1.9.1 for this are quite a mess. Mostly due to the fact that I was tired and in a hurry.

Summary of what the status is now:

* relbranch: changed min/maxVersions similar to what was done for Lightning
* relbranch: changed version to 0.6b1
* default: changed min/maxVersions to @SEAMONKEY_VERSION@
* default: changed version to 0.6b2pre

Now the mess of revids on comm-1.9.1

relbranch: 92f94a04799e af2006a75975 77a5ba0f4d1b 1a39e19621ff
default: 3fbcb74e85ca 2002ab9c8bc4 daf3188c3e3f

I promise I'll be more careful next time!
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.7pre) Gecko/20091212 Lightning/1.0b2pre SeaMonkey/2.0.2pre - Build ID: 20091212001002

with Lightning & gdata-provider builds from ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-1.9.1/linux-xpi-linux/1260650303/ dated 2009-12-12 19:56 UTC

Addons Manager doesn't say "Incompatible with SeaMonkey 2.0.2pre" anymore (in fact, _this_ build supports _only_ Sm 2.0.2pre: why not at least 2.0b2 to 2.0.2pre like Lightning, or even 2.0b2 to 2.0.* ? well, that's not for me to decide).
=> verified1.9.1

I don't use comm-central versions yet, someone else please verify that.
Keywords: verified1.9.1
(Assignee)

Comment 9

7 years ago
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.