DIVs with padding are too wide

VERIFIED DUPLICATE of bug 50449

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 50449
18 years ago
12 years ago

People

(Reporter: Florian Bischof, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
a DIV like this

<div stlye="width:200px;padding:25px">...</div>

will be 250px wide - not 200px as defined by the width-attribute.
The padding should be applied *within* the div, shouldn't it?
(Reporter)

Comment 1

18 years ago
Created attachment 15102 [details]
Example showing the div-padding-width-problem...
(Reporter)

Comment 2

18 years ago
Sorry, there's a typo in the attached example. It should read "This is a 250px
wide DIV"
width is the content width exclusive of padding.

*** This bug has been marked as a duplicate of 50449 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
See http://www.w3.org/TR/REC-CSS2/box.html#box-dimensions and do not rely on
Internet Explorer for checking. IE is very buggy.
Status: RESOLVED → VERIFIED

Comment 5

12 years ago
*** Bug 330323 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.