Open Bug 534021 Opened 13 years ago Updated 7 years ago

Tb annoying IMAP user with error popup "Mailbox isn't selectable:" (server doesn't return \Noselect in LSUB response)

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
defect
Not set
normal

Tracking

(Not tracked)

REOPENED

People

(Reporter: temnota.am, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.5) Gecko/20091123 Iceweasel/3.5.5 (like Firefox/3.5.5; Debian-3.5.5-1)
Build Identifier: 

Every time if I select folder "test" in my IMAP account, thunderbird pop-up warning window with message "Mailbox isn't selectable: test".
Since dovecot allow use this setup - please, remove this annoying pop-up.


Reproducible: Always
Can you provide an imap log for when this happens  and the start of the imap negociation phase too ? Getting an imap log is described at https://wiki.mozilla.org/MailNews:Logging.

Once you have the log make sure to remove private data from it and attach it to this bug using the add an attachment link above.
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Summary: Thnderbird annoying IMAP user with error popup "Mailbox isn't selectable:" → Tb annoying IMAP user with error popup "Mailbox isn't selectable:"
Version: unspecified → 1.9.1 Branch
Attached file imap log with error.
We don't realize the folder is not selectable, because LSUB on the imap server is not telling us that. You might try bringing up the imap subscribe ui (File | subscribe) because the commands we issue there should make the imap server tell us the folder is not selectable.

But ultimately we just need to stop this being a modal alert.
In subscribe ui this folder not selectable.
Yeah, I didn't want you to select it - I just thought bringing up the subscribe UI might make TB realize the folder is NOSELECT. And judging from the subscribe UI, that's true. Do you still see the alert when you try to select the test folder now?
Attached file imap.2.log
Yes, and warning pop-ups every time when I select Inbox folder.
If you select the inbox, bring up the context menu, and select folder properties, and then rebuild index, it will stop trying to copy a message to that folder.
Do you have a log from a session where you bring up the subscribe UI?
Attached file open subscribe UI log
Start tb3, open subscribe UI, close tb3.
(In reply to comment #10)
> Created an attachment (id=417262) [details]
> open subscribe UI log
> 
> Start tb3, open subscribe UI, close tb3.
for others' future reference (not that it applies in temnota's case) ... http://diegosmusings.blogspot.com/2008/06/thunderbird-imap-mailbox-isnt.html
"test" is not selectable == "test" has subfolders which are selectable
                            (mails can be held in the subfolders)
Is it right?
If yes, is next a workaround?
(1) Unsubscribe "test", with keeping subfolders subscribed.
(2) Restart Tb and check subscription status, until "test" is shown in grayed
    out/in Italic at folder pane as expected.
(3) Click "test"
Summary: Tb annoying IMAP user with error popup "Mailbox isn't selectable:" → Tb annoying IMAP user with error popup "Mailbox isn't selectable:" (server doesn't return \Noselect in LSUB response)
can you reproduce this using a current version of thunderbird?

if you are unable to reproduce, please close by setting stats to resolved, and resolution to WORKSFORME or another appropriate setting.

If you are able to reproduce, add new details, and a testcase if one does not already exist in the bug report.
Whiteboard: [closeme 2012-03-25]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
I seem to be having this issue.  DOVECOT is the imap server.  TB 15.0.1.

I've reduced the problem somewhat.  I tried the suggestion in (13).  No help.

I created a folder under INBOX, call it "X".  I realized this was a mistake, so I deleted it.  I then re-created it as "X/".  Next I created some subfolders of X.  The first one is called "A".

Now, TB is confused about X, and I get the "Mailbox isn't selectable:"  prompt.
All that's necessary is to close and re-open TB with that folder selected.

I took a trace (which is busy and tells more of my life than I care to post.)  But here are the essentials.

TB logs in to the server.  The usual uprade to TLS. TB sends ID, LSUB "" "*".
A bunch of LSUB responses come back.  

The important thing is that we get
* LSUB (\NoInferiors \UnMarked) "/" "X/A" 

We do NOT get an LSUB response for "X" - which is expected since X is not subscribed.  Nonetheless, when the LSUB list completes, TB immediately sends

9 select "Accounts and Passwords" (CONDSTORE) and gets:
9 NO Mailbox isn't selectable 


So, it seems to me that TB has some memory of this mailbox, and is blindly doing
a select.  And when it gets the error, it is not refreshing it's cached state.

If I s_client into the server and do a LIST, dovecot is correctly reporting the status:

77 LIST "" "X"
* LIST (\Noselect \HasChildren) "/" "X"
77 OK List completed.

I have tried "Repair" on the folder to see if that will make TB update its type, but the symptom does not change.

I have enabled the DOVECOT work-arounds for TB (tb-extra-mailbox-sep and tb-lsub-flags), this didn't solve the problem (and the traces described above are after enabling them.)

I'm willing to gather more data if it will help, but I suspect that the diagnosis can be advanced from your end from what I found.

Thanks!
Status: RESOLVED → REOPENED
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Resolution: INCOMPLETE → ---
Whiteboard: [closeme 2012-03-25]
Depends on: 799821
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.
You need to log in before you can comment on or make changes to this bug.