Closed Bug 534096 Opened 11 years ago Closed 6 years ago

beaurivage.com -- XML Parsing Error when visiting site in non-Firefox Gecko browsers due to busted user-agent sniffing

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: marcia, Unassigned)

References

()

Details

Attachments

(1 file)

Attached image Screenshot of Error
Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.3a1pre) Gecko/20091210 Minefield/3.7a1pre.

STR:
1. Visit site
2. Observe attached screenshot

This site renders correctly using the latest 1.9.2 nightly.
The site is determining the MIME type based on User-Agent sniffing:  if the UA string contains "Firefox" they send as text/html (twiddle the general.useragent.extra.firefox pref in about:config), but if it contains Namoroka instead (or Minefield) they send as application/xhtml+xml.  The site is, in fact, invalid XML.

-> tech evangelism
Assignee: nobody → english-us
Component: Layout → English US
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified
Marcia, can you take this and contact them?
Blocks: geckoisgecko
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Summary: XML Parsing Error when visiting site → beaurivage.com -- XML Parsing Error when visiting site in non-Firefox Gecko browsers due to busted user-agent sniffing
sure

(In reply to comment #2)
> Marcia, can you take this and contact them?
No issue. This is fixed. or the site has changed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.