Status

--
enhancement
RESOLVED WONTFIX
9 years ago
9 years ago

People

(Reporter: morganrallen, Unassigned)

Tracking

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4
Build Identifier: 

Create a new Object Class that has magic Catch All methods that are called on setting or gettings of the objects properties. This allows for things like abstraction of special objects or services. This is more powerful then __definePropery__ because these are called on every property with out advanced knowledge of the names.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 417014 [details] [diff] [review]
Adds CatchAll object

Basic use.

jetpack.future.import('util.CatchAll');
var c = new jetpack.util.CatchAll(), data = {};
c.__get = function(v) { return data[v]; };
c.__set = function(v, vv) { return data[v] = vv; };
c.x = 1;
(c.x == data.x) // == true;
(Reporter)

Comment 2

9 years ago
Created attachment 417058 [details]
Updated CatchAll

Updated CatchAll to add support for all FlexibleWrapper methods. Added second small demo. Shows complex, replicating objects.
Attachment #417014 - Attachment is obsolete: true
We will be monitoring all these issues after the rebooted Jetpack code base is released in the first week of March to ensure their causes are not duplicated. Many of the bugs/issues with the prototype version of Jetpack will be made irrelevant given the structure of the new SDK.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.