Closed Bug 534111 Opened 12 years ago Closed 12 years ago

Sending of message failed. An error occurred sending mail: Unable to authenticate to SMTP server mail.optonline.net. It does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Uncheck 'Use name and password' for that server

Categories

(MailNews Core :: Networking: SMTP, defect)

1.9.1 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 524868

People

(Reporter: john, Unassigned)

Details

(Whiteboard: [has protocol logs][workaround comment 4])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: 3.0

After downloading thunderbird 3.0, I am unable to send out any emails. The previous version, 2.xxxx worked fine. I now get a message  - Sending of message failed.
An error occurred sending mail: Unable to authenticate to SMTP server mail.optonline.net. It does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Uncheck 'Use name and password' for that server or contact your service provider.
I have tried all the obvious fixes - Please Help or tell me how to get 2.xxx back.

Reproducible: Always

Steps to Reproduce:
1.just try to send out an email
2.
3.
To avoid mismatch between user's thought(user believes SMTP-AUTH is successfull. protected at least by username/password) and real behaviour of SMTP server(doesn't support SMTP-AUTH), i.e. for seurity reason, Tb 3 won't connect to SMTP server without SMTP-AUTH if user requested SMTP-AUTH by checking "Use username and password".

Follow the message, or use SMTP server who supports SMTP-AUTH properly as default SMTP server with selecting "use default server(SMTP)" for identities if possible, please.
 
I get the same error and should not. This should not happen! This has never been a problem before. How do I turn off use authentication? 

"Sending of message failed.
An error occurred sending mail: Unable to authenticate to SMTP server smtp-server.triad.rr.com. It does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Uncheck 'Use name and password' for that server or contact your service provider.
(In reply to comment #2)
> I get the same error and should not. This should not happen! This has never
> been a problem before. How do I turn off use authentication? 
> 
> "Sending of message failed.
> An error occurred sending mail: Unable to authenticate to SMTP server
> smtp-server.triad.rr.com. It does not support authentication (SMTP-AUTH) but
> you have chosen to use authentication. Uncheck 'Use name and password' for that
> server or contact your service provider.

I should add that I can use Thunderbird 3.0 for accessing my POP Gmail account, but not my RoadRunner accounts, which are my main accounts. I set up the Gmail just to send this registration in.
The SMTP settings are independent from your incoming server settings. Where did you uncheck the box? In Tools > Account Settings, in the list on the left, go all the way down to "Outgoing Server (SMTP)" and select the RoadRunner server. Click on Edit and uncheck "Use name and password" there. You may still need authentication for your incoming server to pick up your mail.
(In reply to comment #2)
> I get the same error and should not. This should not happen! This has never
> been a problem before. How do I turn off use authentication? 
> 
> "Sending of message failed.
> An error occurred sending mail: Unable to authenticate to SMTP server
> smtp-server.triad.rr.com. It does not support authentication (SMTP-AUTH) but
> you have chosen to use authentication. Uncheck 'Use name and password' for that
> server or contact your service provider.

I should add that I can use Thunderbird 3.0 for accessing my POP Gmail account, but not my RoadRunner accounts, which are my main accounts. I set up the Gmail just to send this registration in.
'Problem' resolved. Thanks
Hello, I am new here so please excuse me if I'm not following proper protocol.  I have the same error.  I have been using TB 2 for several years with no problems.  I just upgraded to TB 3.0 and now I am unable to send e-mail.  If I am on Campus using the intranet I get the error:

"Sending of message failed.  An error occurred sending mail: Unable to authenticate to SMTP server smtp.uwo.ca. It does not support authentication (SMTP-AUTH) but you have chosen to use authentication. Uncheck 'Use name and password' for that server or contact your service provider."

When I go into my settings and uncheck the "use name and password" then I am able to send mail.  However, if I am outside of campus I must then re-enable the name and password.  In TB 2 I had to have the name and password enabled in order to send e-mail from on or off campus.  I have attached an SMTP log from on campus and off campus with a successful and unsuccessful attempt to send in each case.  If you require any more information please ask.
Attached file OFF Campus SMTP log
Attached file ON-Campus SMTP log
Attachment #417264 - Attachment description: SMTP log → On Campus SMTP log
Component: General → Networking: SMTP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.smtp
Whiteboard: [has protocol logs]
Version: unspecified → 1.9.1 Branch
In essence, this is what bug 527078 comment #3 was asking for, which was duped against bug 524868. The underlying problem is that it is now considered a "hard" error if authentication is configured but not asked for by the server. If the server distinguishes between trusted and untrusted connections, this requires to specify two separate SMTP servers for the same connection and to switch between them as necessary. The other issue for which this bug was opened and which is covered in bug 524868 too is that the error message may not be easy to understand, and that the dialog doesn't offer a button to unset authentication (either for that specific connection or in general for all future connections for this server as well). These two cases are close and need a common solution anyway.
(In reply to comment #8)
(Log-A)
> SMTP log
> 0[1829140]: SMTP Send: EHLO [192.168.1.2]0[1829140]: SMTP entering state: 0
> 0[1829140]: SMTP Response: 250-AUTH PLAIN LOGIN
> 0[1829140]: SMTP Response: 250-AUTH=LOGIN PLAIN
If no SMTP-AUTH(login) because of uncheck of "use username password", server retruns next.
> 530 5.7.0 No AUTH command has been given.

At Campas, you use ADSL modem+DHCP?  

(In reply to comment #9)
(Log-B)
> Off-Campus SMTP log
> 0[1829140]: SMTP Send: EHLO [129.100.60.137]0[1829140]: SMTP entering state: 0
> No 250-AUTH response
If "use username password" is checked, Tb3 issues the warning, because no AUTH response.

When "Off-Campass", do you directly connect to LAN?

Your SMTP log.
> SMTP Connecting to: smtp.uwo.ca
Whois output.
> C:\wada\REXX>whois 129.100.60.137
> OrgName:    University of Western Ontario
Log-A is for "Off-Campas" and Log-B is for "At Campas", isn't it? 

If so, phenomenon is that, when you are at Campas, your SMTP server says;
  there is no need of SMTP-AUTH because you are in Campas.
but "no AUTH response" is "SMTP-AUTH is not supported yet" for Tb.
Then Tb3 says;
  unable to do SMTP-AUTH according to your request by checking "use username
  and password", because of no AUTH response.

If ISP you use at home starts "outbound port 25 blocking", you can't connect to port=25 of SMTP server. So many SMTP servers support "message submission port". 
Patrick, does you server support "message submission port"(port=587)?
If yes, will "port=587 instead of port=25" be a solution?
Whiteboard: [has protocol logs] → [has protocol logs][workaround comment 4]
Attachment #417264 - Attachment description: On Campus SMTP log → OFF Campus SMTP log
Attachment #417265 - Attachment description: Off-Campus SMTP log → ON-Campus SMTP log
I'm not a computer pro but I'll try to answer everything I can:

(In reply to comment #11)

> At Campas, you use ADSL modem+DHCP?  

No, on campus there is no ADSL modem but there is DHCP.  You connect straight into the wall plug.


> When "Off-Campass", do you directly connect to LAN?

When Off-campus I am using an ADSL modem and connecting to the schools smtp server on port 465 (same port as on campus).


> Log-A is for "Off-Campas" and Log-B is for "At Campas", isn't it? 

This is correct I had given the wrong titles and have now corrected it.
 
> If so, phenomenon is that, when you are at Campas, your SMTP server says;
>   there is no need of SMTP-AUTH because you are in Campas.
> but "no AUTH response" is "SMTP-AUTH is not supported yet" for Tb.
> Then Tb3 says;
>   unable to do SMTP-AUTH according to your request by checking "use username
>   and password", because of no AUTH response.

I believe this is the case, however using TB 2 with the exact same set up (using the username/pass) the messages are sent.  Our schools ITS have indicated that this is the correct way to connect to the server and have a step-by-step guide for how to set it up on TB 2.

> If ISP you use at home starts "outbound port 25 blocking", you can't connect to
> port=25 of SMTP server. So many SMTP servers support "message submission port". 
> Patrick, does you server support "message submission port"(port=587)?
> If yes, will "port=587 instead of port=25" be a solution?

Perhaps I am not understanding.  From home I am able to successfully send mail as long as I change the setting to re-enable "use name and password for authentication".

This however is not an ideal way to run the program however as I constantly move from home to work and having to change this setting 4 times daily is ridiculous.  Why was TB 2 able to handle this smtp transaction properly?

I think right now that the only possible work around will be to set up two identities.  But really, I think I'm just going to go back to TB 2 as it works properly, has compact headers and reply all options, but those are whole other issues with TB 3.
(In reply to comment #12)
> When Off-campus I am using an ADSL modem and connecting to the schools smtp
> server on port 465 (same port as on campus).

Ok, apparently the server distinguishes by the incoming IP address whether or not authentication is needed. However, port 465 - though frequently used - is not an officially registered port. WADA's suggestion was to use the official SMTP submission port 587 (possibly with STARTTLS) instead, which always would require authentication. If your server doesn't support the official submission port in that way, that's not an option either, but may be worth to check with your people if it's just a configuration option.

> I believe this is the case, however using TB 2 with the exact same set up
> (using the username/pass) the messages are sent. ...
> Why was TB 2 able to handle this smtp transaction properly?

It is handled more strictly in 3.0 now to avoid the ambiguity of whether or not 
authentication is sent. This obviously causes issues for servers which can be accessed from trusted and untrusted networks, and do not allow authentication from a trusted network as in your case.

I could imagine a 3-state setting to cover these cases: don't authenticate,
use name and password, and authenticate if the server requests it. This third setting would need to be set on purpose, thus the user shows that he or she is aware of its function (but then, "TLS if available" was just removed which had a similar logic...).
(In reply to comment #13)

Just attempted on campus with port 587 ("Use name and password" enabled Connection Security "STARTTLS").

The mail was successfully sent.  I will try using these same setting from home late today and post.  If also successful, then this is a viable work-around in my case.
Where's the bug here? From what I see, the message is entirely correct.

Just because the behavior is different from 2.0 (2.0 fell back to no auth, if server didn't offer any, despite the fact that the prefs explicitly said to use auth) doesn't mean that it's a bug.

As for port 587, not that the new account wizard automatically uses 587, if available, and the SMTP server there requires auth (per spec, and apparently in reality at that university).
s/not that/note that/
It depends how you define "correct" in the context of usability.

The initial description points out an issue if you have an SMTP server which won't ask for authentication, but unfortunately any 2.0 profile was set up with a user name and password unless the user went back to the Account Manager and changed it manually (see bug 524868 comment #13 why this is the case). This has nothing to do with the new account wizard, it's a migration issue combined with a flaw in the old account wizard always setting authentication for SMTP.

Starting with comment #7, this morphed into a similar case as bug 534158, dealing with SMTP servers that have different requirements for local versus remote access, which can no longer be covered with a single setup.

Thus, the question is (here or in bug 524868 to consolidate all those cases), anything that needs to be covered here or shall it be left up to the user to figure out what to do, requiring to switch identities or servers? I think there is also a bug pending somewhere to ask for allowing multiple SMTP servers to be defined and tried in sequence until one is found that works.
> it's a migration issue

Yes.

The bug wasn't filed like that, though. It complains about an error message that is entirely correct and even tells the correct workaround (although the wording could be clearer, and I have a patch in a different bug that makes it clearer). The bug as reported is WORKSFORME.

> which can no longer be covered with a single setup.

Wrong, use port 587, see above.
... *if* the server supports it and does it right.  ;-)

I'd suggest to consolidate all those bugs into bug 524868 to handle migration issues and anything that needs to be done, but let's wait for Patrick to confirm that his issue is fixed as well before duping it.

As for supporting a third 2.0-like "use authentication if requested" option, that's the usual trade-off between requiring that the server does it right and declare anything beyond that a won't-fix, or to accommodate such cases so that the affected users won't have to suffer.
(In reply to comment #19)
> ... *if* the server supports it and does it right.  ;-)
> 
> I'd suggest to consolidate all those bugs into bug 524868 to handle migration
> issues and anything that needs to be done, but let's wait for Patrick to
> confirm that his issue is fixed as well before duping it.

Good idea.
Ok, so I have tried it from off-campus now and here are my results:

Using port 587 with use name and password disabled does not work
Using port 587 with use name and password enabled (SSL/TLS) does not work
Using port 587 with use name and password enabled (STARTTLS) works.  

When using port 465 with use name and password (SSL/TLS) (as advised by campus ITS) it works.

So I guess this is resolved for me now.  However, this behaviour is very vexing for a normal user like me, as it involves changing settings that aren't obvious (like going from the standard port 465 SSL connection to 587 with STARTTLS) nor documented anywhere that I could find.

Thank you all for your help!
You are welcome. As suggested in comment #19 and seconded in comment #20, I'm resolving this now as a duplicate of the other (confirmed) bug on handling such cases a bit more gracefully.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 524868
(In reply to comment #22)

I also think that Patric's comment #7 is same problem as bug 524868.
But original comment #0 is for next, I believe, as no response to comment #1.
  Even though server doesn't support SMTP-AUTH,
  user incorrectly checked "use username and password". 
Majority of "Unable to authenticate to SMTP server ..., Uncheck 'Use name and password' ..." after upgrade to Tb 3 is comment #0 case.
rsx11m, "hi-jacking of original problem of comment #0 by issue of comment #7" is right action? 

"morphing of this bug by comment #7" may be better for us to avoid misunderstanding of this bug, because "no response from bug opener" and majority of comments in this bug is for issue of bug 524868. 
So, I'm not opposite to duping.
Given that there are various flavors of this error message currently out there as bugs I'm getting confused myself which one is covered where (notwithstanding the question if it's really a bug or if it's an obscure but important use case that should be covered). Patrick's problem is closer to bug 534158, whereas John's problem was closer to bug 524868. Those are different issues, but could be handled in a consolidated way in one bug (or split over those two as cases #1 and #2 of bug 524868 comment #12.

Hi-jacking of a bug is in general not a good idea, but in this case the issues were less clear around comment #7 than they are now at comment #22...
You need to log in before you can comment on or make changes to this bug.