preventDefault on CTRL + SPACE keydown doesn't work

RESOLVED DUPLICATE of bug 435164

Status

()

defect
RESOLVED DUPLICATE of bug 435164
10 years ago
3 years ago

People

(Reporter: jarben, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

when we call preventDefault inside keydown event handler and press CTRL + SPACE, system contex menu is shown. This is OK in firefox on Windows, Linux and also Chrome/Safari on Mac so I expect is not a unpreventable event. 

Reproducible: Always

Steps to Reproduce:
1. attach a function to keydown event
2. call preventDefault on event object
3. press CTRL + space
Actual Results:  
system context menu is shown

Expected Results:  
system context menu should be prevented

This is OK in firefox on Windows, Linux and also Chrome/Safari on Mac so I expect is not a unpreventable event.
Based on https://bugs.eclipse.org/bugs/show_bug.cgi?id=391949 I think this is now working.  Please close if you agree.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 435164
You need to log in before you can comment on or make changes to this bug.