Cannot build the XULRunner mac package

RESOLVED DUPLICATE of bug 558098

Status

RESOLVED DUPLICATE of bug 558098
9 years ago
3 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
After I've build xulrunner, if I do "make package" in the objdir I get the following error:

Creating package directory...
building file list ... rsync: link_stat "/Users/dave/mozilla/build/xulrunner/dist/xulrunner-1.9.3a1pre.en-US.mac-pkg.pkg" failed: No such file or directory (2)
done

This seems to be a disparity between the path used to create the pkg and then the rsync calls:

http://mxr.mozilla.org/mozilla-central/source/xulrunner/installer/mac/Makefile.in#98
http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/installer/packager.mk#383
(Reporter)

Comment 1

9 years ago
The package is created at dist/xulrunner-pkg/xulrunner-1.9.3a1pre.en-US.mac.pkg and rsync attempts to copy it from dist/xulrunner-1.9.3a1pre.en-US.mac-pkg.pkg
Setting a forward dupe to bug 558098 as that has deps set on it. I'll transfer comment #1 over since that's the same problem bear's seeing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558098
(Assignee)

Updated

3 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.