Closed Bug 534297 Opened 12 years ago Closed 12 years ago

IMAP Sync downloads the same messages over and over

Categories

(MailNews Core :: Networking: IMAP, defect)

1.9.1 Branch
x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 534835

People

(Reporter: rockflip, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5 (.NET CLR 3.5.30729)
Build Identifier: 

I have a GMail IMAP account set up in TB3.  When watching the activity monitor, it repeatedly syncs the same messages over and over to bring my inbox up to date.  Because of this constantly downloading, I hit my bandwidth limit for Gmail if I leave TB running for a few hours and am locked out of my account for 24 hours (except for webmail).

Disabling sync fixes the problem, but I want to have offline access.

Thanks!

Reproducible: Always

Steps to Reproduce:
1. Set up Gmail IMAP account in TB3
2. Turn on syncing
3. Watch the Activity Monitor
Actual Results:  
Bring Inbox up to date downloads 93 messages, and then again a few minutes later, and again and again
TB3 final or Beta ?
Beta would be bug 517466 and we have bug 532415
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Version: unspecified → 1.9.1 Branch
Happens in 3.0b4, 3.0 final, and 3.0.1 nightly.

Bug 517466 only talks about startup, my mail download sync keeps happening if the app is left open.
It's happening to me as well on both IMAP accounts hosted on Gmail and on Dovecot.

I'm using Thunderbird 3 final release on Windows.  (Note that this issue doesn't rear its head on Linux.)

Additionally, I get weird stuff happening like 'Downloading 8168 of 6205 in Inbox'.

The constant resyncing of messages that have already been synced is only happening in Inboxes.  It is not happening in any other folders.

There is additionally a few things different in my situation from the original poster's situation:

1.  I upgraded from Thunderbird 2.0.0.25 (and Thunderbird 3 took all the settings from it)
2.  I additionally had Shredder 3.0b4 installed on my machine (it's since been removed, and Thunderbird 3's still having issues with IMAP sync).
This issue is still constantly happening for me.  And as I stated before, it's still only happening on Windows XP, and not on Linux.

Just thought I'd mention that it's a recurring problem that's not going away.

Thanks.
Additionally, after it's been doing it for a while, and I try to open an Inbox (not always the same Inbox, every time...could be gmail, could be dovecot, ...), I get the following message box:

Title:  Alert

MessageBox content:  Unable to open the summary file for Inbox.  Perhaps there was an error on disk, or the full path is too long.
Hello,

Just to add my personal experience. Compared to comment #3 it is not happening only on Inbox for me but in a subfolder of 2nd level

I am with Tb3 release with some 3 add-ons Lightning, Quote Manager and MboxImportExtended.

The Imap server is Exchange 2003.
I am not sure I will be able to produce logs beause I was asked by IT team to stop as I was eating all of bandwith
This is happening for me as well.

My observations - 
It happens only for my "Sent Mail" folder.  This has placed into it by one of my websites, a daily backup.  Which is about 150KB.  So there are over 350 of these in these.

These being larger than the average email, I can constantly see TB re-downloading these.  

Eventually, if I leave TB running, which I always used to do, I get the "Account exceeded Bandwidth limits (failure)" error.

I'm running th latest shredder nightly, with same results.

My other worry here is that it's also eating up my bandwidth and being anti social on my network.....
Whiteboard: dupme
To all problem reporters:

What is file size of offline-store?
  If Inbox, .../Inbox (not .../Inbox.msf).
  If [Gmal]/Sent Mail, .../[Gmal].sbd/Sent Mail.
Does "Compact Folder" resolve problem?
Hello,

Don't have nay  more the mailbox configured because my IT said I was Eating all bandwidth but for sure compacting for me did not the trick.

Kind Regards
Hi, I also support a machine where this happens.  It occurs with Thunderbird 3.0 on Windows XP against an Exchange server.  The INBOX redownloads 38 messages of 900+ every time it's refreshed (even moving away from the inbox and back will redownload these).  The Inbox file size is approximate 28Mb.

The IMAP log shows a FETCH for updated messages, which returns none, and then specifically FETCHs these 38 messages (which don't appear unusual in any way).  The all:5 logging information doesn't provide any reason why thunderbird decided to redownload these messages in particular.

Reading other bugs around this area I thought it might be exchange reporting the wrong size, but this was apparently fixed before 3.0 final was released (bug 518702) and I also couldn't find any mention of the specific strings suggested (such as offline message too small, etc).

What further information can I provide to help get this bug solved?
Mike, can you try a 3.01 build? http://ftp.mozilla.org/pub/thunderbird/nightly/3.0.1-candidates/build1/

There was one additional Exchange size fix in 3.01
Wow, thanks for the incredibly quick response David!

I'll be keeping an eye on it, but initially it looks as though once 3.0.1 does indeed solve the problem.  Once it has downloaded the offending messages after installation it no longer tries to download them again in the future, which is perfect!  Thanks very much!  5:)
Mike, thx for very much for checking this so quickly. Marking dup.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 534835
Sorry to put a dampner on this, but it isn't resolved.

Using the latest shredder nightly, I'm still seeing re-downloading of messages.

This being the Gmail Sent folder.
How big is the Sent folder on disk?
Also, sorry to put a damper on it here as well.  I was not using Exchange for a server; I was using Dovecot, and it also happens on Gmail.
The Sent Folder has grown to 57GB and growing as I watch it....

Amazing, as the Gmail quota is only 7GB!
yeah, once it's past 4GB, it will keep growing. That's a separate bug - https://bugzilla.mozilla.org/show_bug.cgi?id=532323

You'll need to rebuild the index for your gmail sent folder in order to reset it to 0, using edit | folder properties. It will re-download all of your sent folder again, or you could just mark it not for offline use...
(In reply to comment #17)
> The Sent Folder has grown to 57GB and growing as I watch it....
> Amazing, as the Gmail quota is only 7GB!

Check offline-store file size after rebuild-index and auto-sync completion.
If file size is greater than 2GB(4GB if Win), it's problem due to bug 532323.
If file size is less than 2GB(4GB if Win), it's problem of bug 537498 due to bug 532323.
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.