Last Comment Bug 534308 - Request needed for jsshell
: Request needed for jsshell
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
:
Mentors:
: 560144 (view as bug list)
Depends on:
Blocks: 534051
  Show dependency treegraph
 
Reported: 2009-12-11 14:41 PST by Ben Turner (not reading bugmail, use the needinfo flag!)
Modified: 2010-06-18 13:28 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
needed
.7-fixed
needed
.11-fixed


Attachments
Patch (789 bytes, patch)
2009-12-11 14:41 PST, Ben Turner (not reading bugmail, use the needinfo flag!)
jorendorff: review+
dveditz: approval1.9.2.7+
dveditz: approval1.9.1.11+
Details | Diff | Splinter Review

Description Ben Turner (not reading bugmail, use the needinfo flag!) 2009-12-11 14:41:58 PST
Created attachment 417172 [details] [diff] [review]
Patch

See patch.
Comment 1 Jason Orendorff [:jorendorff] 2009-12-11 15:26:27 PST
Comment on attachment 417172 [details] [diff] [review]
Patch

Good ol' scatter.
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2009-12-15 16:08:02 PST
Pushed changeset ea06f16ef9e7 to mozilla-central.
Comment 3 Igor Bukanov 2010-04-18 15:27:10 PDT
*** Bug 560144 has been marked as a duplicate of this bug. ***
Comment 4 Igor Bukanov 2010-04-18 15:33:44 PDT
The bug is regression from the bug 534051. Thus we need the patch from the attachment 0 on the branches where the bug 534051 has landed as the regression prevents running any test cases that involves the scatter function from js shell.
Comment 5 Daniel Veditz [:dveditz] 2010-05-24 20:24:06 PDT
Ben, Igor: does this patch work on the branches or will we need new ones? Please add approval requests as appropriate.
Comment 6 Igor Bukanov 2010-05-25 13:56:37 PDT
Comment on attachment 417172 [details] [diff] [review]
Patch

The patch applies as-is on branches.
Comment 7 Daniel Veditz [:dveditz] 2010-06-07 10:40:09 PDT
Comment on attachment 417172 [details] [diff] [review]
Patch

Approved for 1.9.2.5 and 1.9.1.11, a=dveditz for release-drivers
Comment 8 Ben Turner (not reading bugmail, use the needinfo flag!) 2010-06-18 13:26:01 PDT
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/c8a4fddb11c4
Comment 9 Ben Turner (not reading bugmail, use the needinfo flag!) 2010-06-18 13:28:24 PDT
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/b4765d4b11ce

Note You need to log in before you can comment on or make changes to this bug.