menus using wrong colors

VERIFIED DUPLICATE of bug 57429

Status

SeaMonkey
Themes
P5
normal
VERIFIED DUPLICATE of bug 57429
18 years ago
10 years ago

People

(Reporter: fantasai, Assigned: Joe Hewitt (gone))

Tracking

({classic})

Trunk
Future
x86
Windows 2000
classic

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Overview:
	 - The menu bar in the Classic skin is using 'ThreeDFace', not 'Menu' as
	   its background color.
	 - The menu bar in the Classic skin needs to set the CSS 'color' 
	   property to 'MenuText'. (It is currently left unspecified.)
	 - The menupopup background also needs to be changed from 'ThreeDFace'
	   to 'Menu', especially because it already uses 'MenuText' for its 
	   text.

I haven't been able to test these changes because I don't know where the 
menu.css Mozilla uses is located. (I've found a menu.css in the Classic 
directory, but changes in it don't affect the chrome at all.) However, I think 
this should be an easy fix.

Comment 1

18 years ago
Nice, thanks.  Sending to Joe.
Assignee: hangas → hewitt
(Assignee)

Comment 2

18 years ago
The dithering is actually a part of the skin.  Ben used a transparent 
checkerboard gif over the background of those tabs because he needed to create 
a light color for the background.  He said he couldn't use threedhighlight 
because it clashed with the border of the tab and removed the outset effect.  

Removing the checkerboard would mean we'd either have to use threedhighlight 
and lose the outset look, or perhaps use the lighter color on the selected tab 
which has a bold font and use threedface on the unselected tabs.  
Status: NEW → ASSIGNED
(Reporter)

Comment 3

18 years ago
Are you sure you've got the right bug? This one's about menu text/background 
color, not tabs.
(Assignee)

Comment 4

18 years ago
whoops, I posted that to the wrong bug. sorry.
(Assignee)

Comment 5

18 years ago
Don't think this will get approved for RTM.  Marking P5 Future.
Priority: P3 → P5
Target Milestone: --- → Future
(Reporter)

Comment 6

18 years ago
Found out how to edit/test chrome files -- here's the fix:
file: skin/classic/global/menu.css

line 1:
menubar 
  {
-    background-color      : threedface;
+    background-color      : menu;
+    color                 : menutext; /*didn't exist*/
  }

~line 30:
/* XXX menupopups have to have a color explicitly specified. this is a bug */
menupopup, popup 
  {
-    background-color      : threedface;
+    background-color      : menu;

Don't know whether this rates as a "patch", but it fixes the problem. :)
Works on build 2000100308 on Windows 2000.

Comment 7

17 years ago
Marking as dup


*** This bug has been marked as a duplicate of 57429 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified dupe of bug 57429: "Win classic theme should support system colors"
Status: RESOLVED → VERIFIED

Updated

17 years ago
Keywords: classic

Updated

17 years ago
Summary: [Classic] menus using wrong colors → menus using wrong colors
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.