Closed Bug 534377 Opened 12 years ago Closed 12 years ago

Object literal duplicate-property checking doesn't work for same property as number and as string

Categories

(Core :: JavaScript Engine, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: Waldo, Assigned: Waldo)

References

(Blocks 1 open bug, )

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 file)

See URL.
Attached patch PatchSplinter Review
Attachment #419180 - Flags: review?(jim)
Blocks: es5strict
The cause of this bug was my failure to imagine that this could possibly be the correct semantics. I am so naive.
Attachment #419180 - Flags: review?(jim) → review+
http://hg.mozilla.org/tracemonkey/rev/7bdf4c495189
Whiteboard: fixed-in-tracemonkey
Target Milestone: mozilla1.9.3a1 → mozilla1.9.3a5
http://hg.mozilla.org/mozilla-central/rev/7bdf4c495189
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.