All users were logged out of Bugzilla on October 13th, 2018

viewing certain message crashes mozilla

VERIFIED DUPLICATE of bug 61412

Status

P3
critical
VERIFIED DUPLICATE of bug 61412
18 years ago
10 years ago

People

(Reporter: mozilla-06, Assigned: bugzilla)

Tracking

({crash})

Trunk
Future
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000920
BuildID:    2000092005

When I try to view a certain message, mozilla crashes.

Reproducible: Always
Steps to Reproduce:
In attached mail folder, click on the message with the subject "letzte Version!"

Actual Results:  Mozilla crashes.

Expected Results:  Mozilla should display the message.
(Reporter)

Comment 1

18 years ago
Created attachment 15148 [details]
test case (mail folder)

Comment 2

18 years ago
I have a feeling this is Bug #: 53258  which I am looking at.

- rhp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → M19

Comment 3

18 years ago
*spam*

adding crash keyword...
Keywords: crash

Updated

18 years ago
Target Milestone: M19 → Future
QA Contact: esther → sheelar
(Reporter)

Comment 4

18 years ago
This bug seems to be unrelated to bug 64601 - replacing all 0x0d0a with 0x0a
didn't help.

AFAIK the mail got damaged (changed) by drag'n'dropping it to another folder.
I'll file another bug for that effect.
(Reporter)

Comment 5

18 years ago
This message contains an 0x0d000a which seems to be causing the crash.

Comment 6

18 years ago
Is it possible to get a stack trace to see where it crashes?
(Reporter)

Comment 7

18 years ago
Created attachment 22630 [details]
Dr. Watson log file

Comment 8

18 years ago
reassigning to ducarroz
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Comment 9

18 years ago
Navin and Jean-Francois, do you think this is a dup of the corruption bug that
occurred when copying messages or the recent MIME top crash? Both have been
fixed. Oliver, if you use a recent build, do you still crash?
(Assignee)

Comment 10

18 years ago
the 0x0d000a database corruption has been fixed by Navin and I added a patch in
mine to support remaining 0x0d000a. Therefore I am pretty sure this is already
fixed.
Status: NEW → ASSIGNED
(Assignee)

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 61412 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

18 years ago
Indeed, this does not crash any more. Good work!
Per reporter's and engineer's comments, marking VERIFIED DUP. (The bug it's
duped against was fixed.)
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.