"true or false" comments for localized prefs in messenger.properties need to be LOCALIZATION NOTEs, and need to be clearer

RESOLVED DUPLICATE of bug 550411

Status

MailNews Core
Localization
RESOLVED DUPLICATE of bug 550411
8 years ago
3 years ago

People

(Reporter: philor, Unassigned)

Tracking

Bug Flags:
wanted-thunderbird +

Thunderbird Tracking Flags

(thunderbird5.0 wanted)

Details

(URL)

(Reporter)

Description

8 years ago
We have at least two things, mail.addr_book.displayName.lastnamefirst and mail.addr_book.show_phonetic_fields, where the value is supposed to be a localized boolean pref, but because we have a comment that doesn't admit that it's a LOCALIZATION NOTE, which isn't as explicit as it could be about how the valid values are "true or false (untranslated)," we have a ton of values like falsk, nie, and தவறு.

It's not the end of the world, at the moment at least, since they both mostly want to be false, and the code treats any value other than exactly "true" as false, but it's not pretty, and confusing for localizers like the one who brought it to my attention.
Ok, from what I can see the following locales are affected:

- ar (Thunderbird)
- be (Thunderbird and SeaMonkey)
- bn-BD (Thunderbird)
- ca (Thunderbird and SeaMonkey)
- es-AR (SeaMonkey)
- es-ES (SeaMonkey)
- eu (Thunderbird)
- ga-IE (Thunderbird)
- gl (Thunderbird and SeaMonkey)
- it (Thunderbird and SeaMonkey)
- pl (SeaMonkey)
- ta-LK (Thunderbird)
- uk (SeaMonkey)

These locales are also affected, but are not in our list of supported locales:
- hi-IN (Thunderbird)
- mk (Thunderbird)

CC'ing KaiRo and TB localizers on this.

Comment 2

8 years ago
I'm pretty sure some of that even come out of not reading comments or L10n notes at all but only values themselves - but if we have proper L10n notes, we can blame it on localizers more easily ;-)

I'd be happy if we would have some tooling to check for problems in cases like that (affects all Mozilla products).

In any case, we should post and rumble on the L10n newsgroup / list about that.

Comment 3

7 years ago
Why not simply use the normal Boolean values? 
I find it very strange to try to localize names of truth values.
To me, this issue is a consequence of bug #550411.
status-thunderbird5.0: --- → wanted
Flags: wanted-thunderbird+

Comment 4

7 years ago
Both http://preferential.mozdev.org/preferences.html and http://kb.mozillazine.org/Mail_and_news_settings do not reflect this localization hack. 
Moreover, the former contradicts to what Phil Ringnalda (:philor) reports wrt. treatment of "true": it says that "firstname lastname" is used when the value is "false" (rather than "lastname, firstname" if the value is "true"). 

To me, the deviation from straightforward Boolean values, is an abuse of the localization mechanism, which creates all kinds of confusion, since there is now an essentially three-valued logic :-(
(In reply to comment #4)
> Both http://preferential.mozdev.org/preferences.html and
> http://kb.mozillazine.org/Mail_and_news_settings do not reflect this
> localization hack. 

Those are both out of our control and I suggest you contact or provide edits to those pages to the various sites specifically.

> To me, the deviation from straightforward Boolean values, is an abuse of the
> localization mechanism, which creates all kinds of confusion, since there is
> now an essentially three-valued logic :-(

Unfortunately that is a limitation of the system we have and it isn't going to be changed in the short term.

Comment 6

7 years ago
I tried updating the information at both http://preferential.mozdev.org/preferences.html and http://kb.mozillazine.org/Mail_and_news_settings but there is no way to automatically register there online and my email inquiries remained unanswered :-(

It's a shame that there are outdated and thus misleading (unofficial, but very prominent) pages about the Mozilla/Thunderbird preference settings, while apparently there is no official up-to-date page where the details on these settings are properly documented. Or where to find this documentation?

Comment 7

3 years ago
mail.addr_book.displayName.lastnamefirst should be covered by bug 550411.
mail.addr_book.show_phonetic_fields should be covered by bug 118624.

Is there anything else remaining here? Can we dupe this?
Flags: needinfo?(philringnalda)
(Reporter)

Comment 8

3 years ago
You have my permission to do as you like.
Flags: needinfo?(philringnalda)

Comment 9

3 years ago
In the end, both strings got fixed in bug 550411, so I think we can dupe this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 550411
You need to log in before you can comment on or make changes to this bug.