If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No autoscroll in print preview anymore

RESOLVED FIXED

Status

()

Core
Print Preview
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Ilja Sekler, Assigned: smaug)

Tracking

({regression})

Trunk
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091213 Firefox/3.7a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091213 Firefox/3.7a1pre

Autoscroll in print preview doesn't work anymore, a rough regression window:

works: http://hg.mozilla.org/mozilla-central/rev/9af2a428dcb1

fails: http://hg.mozilla.org/mozilla-central/rev/2000e14d36b2

Bug 487667?


Reproducible: Always

Steps to Reproduce:

1. set the preference general.autoScroll to 'true'
2. open print preview e.g. for http://hg.mozilla.org/mozilla-central/rev/180966423a3c
3. hold down the mouse wheel

Actual Results:  
No autoscroll icon appears, no autoscroll.


Expected Results:  
Autoscroll icon shows and autoscroll starts.
(Reporter)

Updated

8 years ago
Keywords: regression
Version: unspecified → Trunk
Also reproducible on Windows Vista.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: x86 → All
Based on Works / Fails changesets in comment 0, the regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9af2a428dcb1&tochange=2000e14d36b2

In that range, bug 487667 indeed looks most suspicious.  Tentatively marking dependency.
Blocks: 487667
(Assignee)

Comment 3

8 years ago
Heh, I didn't even know that autoscroll works with print preview :)
Assignee: nobody → Olli.Pettay
(Assignee)

Comment 4

8 years ago
Created attachment 417755 [details] [diff] [review]
remove about:blank check

I don't quite understand why the about:blank check was added in Bug 277847,
but anyway removing it now doesn't seem to regress that bug, at least not on
linux.

It is very possible that about:blank documents have huge presentation and so
autoscrolling should be enabled. Currently autoscroll doesn't work when print previewing about:blank documents.
Attachment #417755 - Flags: review?(mconnor)
(Assignee)

Updated

8 years ago
Blocks: 277847
Comment on attachment 417755 [details] [diff] [review]
remove about:blank check

I wish I knew... it doesn't make a lot of sense, but that was like five years ago... a lot of stuff has changed since then...
Attachment #417755 - Flags: review?(mconnor) → review+
(Assignee)

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/283116b8fff1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.