Session Restore losing, duplicating and replacing windows after crash

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
major
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: JLinks22, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5

I leave 100+ tabs open at any one time. I leave firefox open and leave my computer on constantly. This allows me to peruse everything I'm looking up or reading for various projects I'm working on or whatnot, without having to load them again, as well as preserving pages that may be changed or deleted; all of which cannot be done with bookmarks. I try to categorize them into 3 or 4 windows.

When leaving firefox on for so long, crashes are bond to happen. And with so many tabs open, they tend to happen every 2 to 5 days. It's really annoying. But what's worse is that I loose entire windows of tabs. It maybe happens 2 out of every 3 crashes. And about 2 out of every three times it happens, the missing window is in History > Recently Closed Windows. But there's still the other times when the window is completely lost. It can also happen to multiple windows at the same time.

Normally, when this happens, one of the other windows is duplicated in it's place. And sometimes the duplicated window has the wrong amount of tabs open, with extra empty tabs. Also the Back/Forward history can be empty, which is bad for me since if any webpage is slowing down Firefox, I'll hit the Home button then hit Back when I want to get to it again. Windows also tend to become resized, despite them all being full screen, which is not caused by any webpage's scripting, out of order, and on the wrong monitor. (I have two monitors)

This has been occurring for a VERY long time. The details may have changed slightly, but it's not a new problem. I've been waiting probably years for this to be fixed, and I'm finally angered into filing this bug. I expect my browser to be reliable, not loose my data time after time again. This has occurred on every computer I have used for an extended period of time, and on numerous versions of Firefox.

Also, the same thing happens when I click the "Restart Tabbed" button from the Toolbar Buttons extension. But I tried duplicating it by disabling/re-enabling add-ons and clicking the "Restart Firefox" button that drops down above the add-ons list, and the error doesn't occur (anymore, at least).

Reproducible: Sometimes

Steps to Reproduce:
1. Open numerous tabs in some windows (I tried 30 tabs of random pages without flashes per window, in 3 windows)
2. Make it crash? (Alt+Ctrl+Del > Processes > End Process) (or press the Restart Tabbed button in the Toolbar Buttons extension)
3. Reopen firefox
Actual Results:  
Not always, but much of the time a window may be missing or replaced by a duplicate of another. On one attempt only one of the windows opened at all.

Expected Results:  
All windows and tabs should remain.
(In reply to comment #0)
> Also, the same thing happens when I click the "Restart Tabbed" button from the
> Toolbar Buttons extension. But I tried duplicating it by disabling/re-enabling
> add-ons and clicking the "Restart Firefox" button that drops down above the
> add-ons list, and the error doesn't occur (anymore, at least).
> 
> Reproducible: Sometimes

I'm confused. Is this reproducible without extensions? Or did disabling extensions fix it?
(Reporter)

Comment 2

9 years ago
As of today's update to 3.5.6, I can no longer cause the bug when just crashing firefox on purpose, with or without any extensions enabled. It still happens if I press the Restart Tabbed button in the Toolbar Buttons extension, though.

If I see it happening when Firefox crashes again, I'll mention it here. In the mean time I guess I'll just have to go to File>Exit and then open Firefox again instead of using the Restart Tabbed button, and hopefully it won't happen again.
(In reply to comment #2)
> As of today's update to 3.5.6, I can no longer cause the bug when just crashing
> firefox on purpose, with or without any extensions enabled. It still happens if
> I press the Restart Tabbed button in the Toolbar Buttons extension, though.

Restart tabbed does not use Firefox's session restore. It does it's own thing which is vastly different.

> If I see it happening when Firefox crashes again, I'll mention it here. In the
> mean time I guess I'll just have to go to File>Exit and then open Firefox again
> instead of using the Restart Tabbed button, and hopefully it won't happen
> again.

I'll resolve this WORKSFORME for now. Reopen if it happens again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Updated

9 years ago
Summary: Session Restore loosing, duplicating and replacing windows after crash → Session Restore losing, duplicating and replacing windows after crash
You need to log in before you can comment on or make changes to this bug.