Selecting Multiple Message Filters to run in other folders

RESOLVED FIXED in Thunderbird 3.1a1

Status

MailNews Core
Filters
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Abraham, Assigned: rkent)

Tracking

({fixed-seamonkey2.0.3, regression})

Trunk
Thunderbird 3.1a1
fixed-seamonkey2.0.3, regression

Firefox Tracking Flags

(blocking-thunderbird3.0 .1+, thunderbird3.0 .1-fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

I Bring up message filters and try to select 10 or 20 filters that I want to run in a folder (ie.  Old inbox)  I am unable to do so.  This worked in previous versions.

I even tried with no theme addons just incase

Reproducible: Always

Steps to Reproduce:
1. Open Message Filters
2. Try to select more than one using shift or any other method??
3. It simply does not highlight more than one
Actual Results:  
It used to highlight more than one and you could select run selected filters on .....  But now it is one by one.  Very Painful

Expected Results:  
Should be able to select all and search
(Reporter)

Updated

8 years ago
Keywords: common-issue?
Version: unspecified → 3.0
(Assignee)

Comment 1

8 years ago
I can confirm that this is happening, plus I tested on TB2 and you could select multiple filters there. So this is a regression. I have not idea why though, as there were very few changes to the filter list editor.
Status: UNCONFIRMED → NEW
Component: General → Filters
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: general → filters
Version: 3.0 → Trunk
(In reply to comment #1)
> I can confirm that this is happening, plus I tested on TB2 and you could select
> multiple filters there. So this is a regression. I have not idea why though, as
> there were very few changes to the filter list editor.

Might be a CORE change !
Keywords: common-issue?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 534890
(Assignee)

Comment 4

8 years ago
I hope to at least look at this bug soon, and if I can fix it I'd like it on the branch.
Assignee: nobody → kent
Status: NEW → ASSIGNED
blocking-thunderbird3.0: --- → ?
(Assignee)

Comment 5

8 years ago
For the record, I changed this to Mailnews Core/Filters because that's where I look for bugs like this. But the FilterListDialog is forked between SM and TB, and only TB sees this problem.
(Assignee)

Comment 6

8 years ago
Created attachment 418917 [details] [diff] [review]
Could it be this simple?

This simple patch worked on my quick tests.
(Assignee)

Comment 7

8 years ago
Created attachment 418934 [details] [diff] [review]
Naaah, allowing multiple selection exposed a delete bug
Attachment #418917 - Attachment is obsolete: true
(Assignee)

Updated

8 years ago
Attachment #418934 - Flags: review?(mkmelin+mozilla)
(Assignee)

Updated

8 years ago
Whiteboard: [needs r mkmelin]

Comment 8

8 years ago
(In reply to comment #7)
> Created an attachment (id=418934) [details]
> Naaah, allowing multiple selection exposed a delete bug


How can apply patch?

Updated

8 years ago
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All

Comment 9

8 years ago
Comment on attachment 418934 [details] [diff] [review]
Naaah, allowing multiple selection exposed a delete bug

Looks good, thx! r=mkmelin
Attachment #418934 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 10

8 years ago
"How can apply patch?"

Normally you would need a development environment setup for this, so that you can compile mailnews code. Do you have this setup? It is not a trivial task.

If you just want this to work for you, I will land this bug in a day or two, and then you will be able to pick it up in a nightly build.
(Assignee)

Updated

8 years ago
Whiteboard: [needs r mkmelin] → [needs landing trunk]
(Assignee)

Comment 11

8 years ago
Checked into trunk http://hg.mozilla.org/comm-central/rev/c7081c7489e2
Whiteboard: [needs landing trunk] → [needs tb 3.0 approval]
(Assignee)

Updated

8 years ago
Target Milestone: --- → Thunderbird 3.1a1
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Attachment #418934 - Flags: approval-thunderbird3.0.1?

Updated

8 years ago
blocking-thunderbird3.0: ? → needed
Attachment #418934 - Flags: approval-thunderbird3.0.1? → approval-thunderbird3.0.1+
Landed on 1.9.1 as <http://hg.mozilla.org/releases/comm-1.9.1/rev/1e428f88e7b4>.
Whiteboard: [needs tb 3.0 approval]
status-thunderbird3.0: --- → .1-fixed

Updated

7 years ago
Keywords: fixed-seamonkey2.0.3
(Assignee)

Updated

7 years ago
blocking-thunderbird3.0: needed → ---
blocking-thunderbird3.0: --- → .1+
You need to log in before you can comment on or make changes to this bug.