Add SSWindowRestoring Event

VERIFIED DUPLICATE of bug 615394

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 615394
8 years ago
7 years ago

People

(Reporter: anant, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
A SSTabRestoring notification is currently available, but a 'SSWindowRestoring' event would be useful to have. Using this, extensions can run code when a window has been restored from the session store.
(Reporter)

Comment 1

8 years ago
The workaround that we can use currently, for those interested, would be to listen for 'domwindowopened' and check if the window type is 'navigator:browser'.
Do you need to know for each window or just when sessionstore is done in general? I'm assuming you mean the first, but if it's the later we do have an observer topic for that.
(Reporter)

Comment 3

8 years ago
We could check for the "session restore done" notification and iterate through all the open windows to achieve the same end goal. However, I think having a separate notification for when a window has been restored will make code using it a lot cleaner and easier to understand as opposed to the workarounds.
I seem to be in the habit of having an idea and implementing it only to realize other people had the idea before me.

Anant - I'm guessing you're long past needing this notification, but I think bug 615394 should cover you.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 615394
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.