Closed Bug 53476 Opened 21 years ago Closed 17 years ago

parent menus accessible from Keyboard while modal dialog is up

Categories

(Core :: XUL, defect, P3)

x86
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: jrgmorrison, Assigned: danm.moz)

References

(Depends on 1 open bug)

Details

Overview Description: 
  Possibly this is a dup, but I couldn't find one for this specific
  defect. Thanks to jimmylee for noting this.

  Parent window menus are still accessible from the keyboard when a
  modal dialog is active (e.g. window.confirm). 
 
Steps to Reproduce: 
1) Bring up an alert:
    <html><body><form>
      <input type="button" name="abutton" value="confirm..." 
             onclick='alert("try to use a ctrl-f, for example");'>
    </form></body></html>
2) Type 'Alt-G B' on Linux

Actual Results:   on Linux, the menus respond (possibly crashes)
Expected Results: menus not accessible

Build Date & Platform Bug Found: 
  2000091908 Linux
   DOES NOT OCCUR ON win32/mac 20000919nn

-> Future
Target Milestone: --- → Future
*** Bug 62544 has been marked as a duplicate of this bug. ***
(Note from bug 62544 : control key shortcuts behave similarly, so ^L with a modal 
window up (like, say, the one you get when you hit ^L) brings up another one.)
My patch for bug # 65521 also fixes this bug. If you think the patch for 65521
is appropriate.
Depends on: 65521
Depends on: 99728
Did bug 65521 fix not fix this? Seems to be WFM in 1.7rc1.
This doesn't appear to be a problem anymore.  Just tried it.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.