Closed Bug 534819 Opened 10 years ago Closed 10 years ago

Create new Talos suite: tscroll

Categories

(Release Engineering :: General, defect, P3)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jrmuizel, Assigned: anodelman)

References

Details

Attachments

(4 files, 2 obsolete files)

Attached patch add tscroll test (obsolete) — Splinter Review
- I'll be the contact person for this test suite.

- This test tests scrolling performance on a set of pages. The result from each page is average scroll time in nanoseconds.

- For now this should only run on trunk on windows, linux and os x.

- Note: The patch contains binaries so it's in git format.
Moving to Future, until we sort priority of this new suite along with the other requests for new talos suites.
Component: Release Engineering → Release Engineering: Future
OS: Mac OS X → All
Summary: Add tscroll talos testsuite → Create new Talos suite: tscroll
Assignee: nobody → lsblakk
too busy with getting try-as-branch in config to touch this in a while, so putting back in the pool.
Assignee: lsblakk → nobody
Mass move of bugs from Release Engineering:Future -> Release Engineering. See
http://coop.deadsquid.com/2010/02/kiss-the-future-goodbye/ for more details.
Component: Release Engineering: Future → Release Engineering
Priority: -- → P3
It's been nearly 3 months since I filed this. When can I expect it to be deployed?
Has this been tested with standlone talos - does it actually run in the talos framework?
Attached file zipped version (obsolete) —
Assignee: nobody → anodelman
We are currently upgrading talos staging, so this will have to wait till we have machines on which to test.
jrmuizel, can you answer the question in Comment 5 above?

We've the Layers project in motion right now which is specifically trying to improve scrolling.  OOPP may also affect scrolling in ways we can't predict.  These two things alone are good reasons to bump this up in priority.  

Alis, how long do we expect the talos staging upgrade to take?  Are there other dependencies?  Anything we can do to help?
(In reply to comment #5)
> Has this been tested with standlone talos - does it actually run in the talos
> framework?

Yes.
(In reply to comment #8)
 
> Alice, how long do we expect the talos staging upgrade to take?  Are there other
> dependencies?  Anything we can do to help?

Corrected spelling of Alice, and hoping to get more details.  Any news?  :)
This is waiting on:

- successful run through talos staging (has been recently blocked as we've been rebuilding talos staging)
- graph server patches to add new test name to staging/production graph server

I will handle the staging, but this is not currently my top priority.  Will update bug as progress is made.
This is currently blocked on availability of staging, which is in use for getting unit tests running on talos boxes.  I'd say that we are 2 weeks out from being able to do a staging run, unless I can find some availability without disrupting the current tests.
I'm setting up a secondary talos staging instance with borrowed production talos slaves as covered in meetings with shaver + joduinn.

I should have initial staging of tscroll overnight.
On what operation systems/branches do we want tscroll run?
Attachment #417644 - Attachment is obsolete: true
Attachment #431418 - Attachment is obsolete: true
Attachment #434429 - Flags: review?(lsblakk)
Attachment #434425 - Flags: review?(lsblakk) → review+
Attachment #434429 - Flags: review?(lsblakk) → review+
(In reply to comment #16)
> On what operation systems/branches do we want tscroll run?

I can't really think of any place not to run it. However, I didn't test it on fennec, so I'm not sure how well it works there.
Blocks: 554757
Attachment #434674 - Flags: review?(lsblakk) → review+
Graph server updates applied to both stage and production dbs.
Comment on attachment 434425 [details] [diff] [review]
[checked in]add scroll test to graph server

changeset:   286:4b4ca01da757
Attachment #434425 - Attachment description: add scroll test to graph server → [checked in]add scroll test to graph server
Attachment #434425 - Flags: checked-in+
Comment on attachment 434674 [details] [diff] [review]
[checked in]turn on tscroll everywhere (all platforms + branches)

changeset:   2213:043064228efb
Attachment #434674 - Attachment description: turn on tscroll everywhere (all platforms + branches) → [checked in]turn on tscroll everywhere (all platforms + branches)
Attachment #434674 - Flags: checked-in+
Comment on attachment 434429 [details] [diff] [review]
[checked in]add tscroll to talos code base (updated talos configs/manifests)

RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/drac.htm,v
done
Checking in page_load_test/scroll/drac.htm;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/drac.htm,v  <--  drac.htm
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/iframe.svg,v
done
Checking in page_load_test/scroll/iframe.svg;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/iframe.svg,v  <--  iframe.svg
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader-scroll.js,v
done
Checking in page_load_test/scroll/reader-scroll.js;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader-scroll.js,v  <--  reader-scroll.js
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader.css,v
done
Checking in page_load_test/scroll/reader.css;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader.css,v  <--  reader.css
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader.htm,v
done
Checking in page_load_test/scroll/reader.htm;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/reader.htm,v  <--  reader.htm
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll-frame.js,v
done
Checking in page_load_test/scroll/scroll-frame.js;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll-frame.js,v  <--  scroll-frame.js
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll.js,v
done
Checking in page_load_test/scroll/scroll.js;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll.js,v  <--  scroll.js
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll.manifest,v
done
Checking in page_load_test/scroll/scroll.manifest;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/scroll.manifest,v  <--  scroll.manifest
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/strips-single.png,v
done
Checking in page_load_test/scroll/strips-single.png;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/strips-single.png,v  <--  strips-single.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/strips.png,v
done
Checking in page_load_test/scroll/strips.png;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/strips.png,v  <--  strips.png
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-downscale.html,v
done
Checking in page_load_test/scroll/tiled-downscale.html;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-downscale.html,v  <--  tiled-downscale.html
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-fixed-downscale.html,v
done
Checking in page_load_test/scroll/tiled-fixed-downscale.html;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-fixed-downscale.html,v  <--  tiled-fixed-downscale.html
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-fixed.html,v
done
Checking in page_load_test/scroll/tiled-fixed.html;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled-fixed.html,v  <--  tiled-fixed.html
initial revision: 1.1
done
RCS file: /cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled.html,v
done
Checking in page_load_test/scroll/tiled.html;
/cvsroot/mozilla/testing/performance/talos/page_load_test/scroll/tiled.html,v  <--  tiled.html
initial revision: 1.1
Checking in sample.config;
/cvsroot/mozilla/testing/performance/talos/sample.config,v  <--  sample.config
new revision: 1.41; previous revision: 1.40
done
Attachment #434429 - Attachment description: add tscroll to talos code base (updated talos configs/manifests) → [checked in]add tscroll to talos code base (updated talos configs/manifests)
Attachment #434429 - Flags: checked-in+
No longer blocks: 554757
Up and running.  All done here.
Can this be marked as RESOLVED FIXED?
Depends on: 555352
This needs to be backed out. The test is permanently orange/red on Linux. See bug 555352.
If a stack is generated and read on linux32 shouldn't that be filed as a crash and then fixed?  I'm not convinced that the problem isn't in the browser - and I wouldn't want to disable the test if it is showing a 'real' crash.
Nick hid the failing Talos boxes, which is probably better than backing this out, yes.
We are going to track failures of this test here bug 555352.

But the rollout of the test was successful, and the work for this bug is done.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
I don't know why we are crashing. However, it seems like tiled-fixed-downscale.html could be taking a really long time. Can we adjust the timeouts?
Increase timeout patch in bug 555352 - not adding to this bug as it is closed.
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.