Closed Bug 534866 Opened 10 years ago Closed 10 years ago

Java and WMP plugins don't load (IPP)

Categories

(Core :: Plug-ins, defect, blocker)

x86
Windows 7
defect
Not set
blocker

Tracking

()

RESOLVED FIXED

People

(Reporter: jmjjeffery, Assigned: benjamin)

References

()

Details

(Whiteboard: [Windows-only, in-process only])

Attachments

(1 file)

Vist test page: http://home.att.net/~cherokee68/wmvtest2.html 

Note, WMP does not open/play the file.  Does not matter if IPC is on/off, still does not play.

No errors noted in Console2
Using latest hourly, cset: http://hg.mozilla.org/mozilla-central/rev/c39745ba3c9e

WMP: MS WMP Plugin 1.0.0.8 
Win 7 64bit
Hrm, on Windows 7, I had to manually install the WMP plugin because the Microsoft installer didn't add registry keys to the registry. But once I did that, the plugin seemed to work fine.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Component: IPC → Plug-ins
QA Contact: ipc → plugins
I don't understand setting this back to unconfirmed.  The 12/14/2009 works, and any build that has been tested after the landing of the OOPP, does not work.

The installler for the WMP plugin has been a long standing issue since Vista, in that the plugin is not installed correctly, and the file must be copied into the plugins folder to work.

What registry key needs changed ???
I marked it as UNCO because it works for me. You may be running into bug 534863, depending on the install path: but if the install path doesn't have any spaces, I can load WMP without any problems.
So basically, this bug affect every single plug-in that installs to "c:\program files".  The only reason Flash is not supported is because it installs to c:\windows\system32\macromed\flash

That is why:
c:\program files\adobe\Reader x.x\...
c:\program files\java\...
c:\program files\quicktime\...
c:\program files\real\...
etc.

are all affected.  There is nothing the user needs to do.  This IS a BUG introduced with the Electrolysis merge.

It's as though the devs either tested only flash or tested on only non-Windows systems.
I meant "...only reason Flash *is* supported..."
The issue with spaces in the path only affects the out-of-process case: if you are experiencing something with in-process plugins, that is a different issue (and I need your help determining better steps to reproduce). We knew that OOPP was not ready to turn on by default, but wanted to land it to get exactly the kind of early testing we're getting right now. Thanks for the help (and please stop complaining).
Running Vista x64 Ultimate I've tried the following:

1. Verified that the WMP plugin is installed and recognized by Minefield.
2. Running yesterday's build from G:\Minefield gives me an embedded WMP on the page linked above.
3. Running today's build from G:\Minefield gives me nothing, no errors, and the plugin is detected with OOPP off.

What else can I do to provide more information?
* Does the WMP plugin appear in about:plugins in both builds? What version number and other data is listed?
* You installed the WMP plugin by copying it to the Minefield/plugins directory?
(In reply to comment #7)
> What else can I do to provide more information?

That's what I'd like to know too.

I strongly believe this has to do with spaces in the name of the plug-in path (regardless of the fact that IPC IS DISABLED), as I've stated, but that seems to be getting ignored.

Try this then:
1. Make sure you have Java installed in its default location of c:\program files\java\...
2. Click this link: http://www.velocitysoftware.com/SHOWCASE/showcase.html
3. An applet is supposed to load, but you will get the following error:

Error: java is undefined
Url: http://www.velocitysoftware.com/SHOWCASE/showset.js
Line: 10
(In reply to comment #8)
> * Does the WMP plugin appear in about:plugins in both builds? What version
> number and other data is listed?
> * You installed the WMP plugin by copying it to the Minefield/plugins
> directory?

Yes.  All my plugins appear in about:plugins, but only Flash will load.
Contents of firefox\plugins:

04/10/2007  04:21 PM           163,256 np-mswmp.dll
05/12/2009  10:46 AM         1,650,992 npdivx32.dll
05/12/2009  10:46 AM            22,904 npdivx32.tlb
05/01/2009  01:02 PM             1,691 npdivx32.xpt
12/15/2009  09:35 AM            69,632 npnul32.dll
01/23/2009  12:01 PM           143,360 npqtplugin.dll
01/23/2009  12:01 PM           143,360 npqtplugin2.dll
01/23/2009  12:01 PM           143,360 npqtplugin3.dll
01/23/2009  12:01 PM           143,360 npqtplugin4.dll
01/23/2009  12:01 PM             2,394 nsIQTScriptablePlugin.xpt
01/23/2009  12:01 PM             4,208 QuickTimePlugin.class
              11 File(s)      2,488,517 bytes
> * Does the WMP plugin appear in about:plugins in both builds? What version
> number and other data is listed?
Microsoft® Windows Media Player Firefox Plugin

    File: np-mswmp.dll
    Version: 1.0.0.8
    np-mswmp

There's an A with a ^ between Microsoft and the Registered Trademark.

> * You installed the WMP plugin by copying it to the Minefield/plugins
> directory?
I used the wmpfirefoxplugin.exe from port25 which installed it into "Mozilla Firefox\plugins" I then copied it into "Minefield\plugins".
ok, I can reproduce with IPC off. We broke Java/WMP in completely different ways in-process and out-of-process.
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: OOPP: Embedded WMP on page does not open → Java and WMP plugins don't load (IPP)
Attachment #417849 - Flags: review?(joshmoz)
Regression from bug 519509
Blocks: 523094, 516509
Severity: normal → blocker
Comment on attachment 417849 [details] [diff] [review]
Set NPPluginFuncs.size, rev. 1

I'm giving this r+ because it does fix the bug, however as a result of this patch we set fCallbacks.size twice on Mac OS X. Please get rid of the line that sets it again in the Mac OS X ifdef.
Attachment #417849 - Flags: review?(joshmoz) → review+
http://hg.mozilla.org/mozilla-central/rev/e517feb23baa fixes review nit
merged to mozilla-central at http://hg.mozilla.org/mozilla-central/rev/4eef63c0c6c9
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [Windows-only, in-process only]
You need to log in before you can comment on or make changes to this bug.