Closed Bug 5349 Opened 21 years ago Closed 21 years ago

<a href=...><img src=...></a> links broken

Categories

(Core :: Layout, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 5886

People

(Reporter: simra, Assigned: joki)

References

()

Details

(Whiteboard: [TESTCASE])

Attachments

(4 files)

Go to the above URL, which, AFAIK, is straightforward, standards-compliant HTML.
At the bottom of the page is a series of images, each of which is embedded in a
<a href=..> tag.  Most of the intended links are obvious, but when an image is
clicked on, the incorrect link is taken (usually redirected to the McGill link,
which is the first on the line).
Status: NEW → ASSIGNED
Target Milestone: M6
There are two problem here that I see:
1. if you load the page and then quit the browser. When you run it again and
look at this page almost all of the images at the bottom fail to load
2. clicking on the alt-text displayed for the links doesn't do anything, i.e. we
don't jump to the link
Assignee: troy → joki
Status: ASSIGNED → NEW
Tom, here's a very simple example that demonstrates the problem of links not
working if they contain a broken image.

<a href="foo.html">Some text and a broken image_ <img src="foo.zzz" alt="the
alternate text"</img></a>

What happens is that the image can't be rendered, so we display its alternate
text instead. In doing that we create an anonymous text content object, and that
may be what is causing the problem. I'm not sure if the event code (I guess, I
don't know much about the flow of control) expects to get a frame with no
content object. Also, because the content object is anonymous it has no document
pointer or parent content pointer.

The frames look like this:

Inline(a)(0)@0157CCC0 {0,0,4485,285} [state=0000001c]<
  Text(0)@0157C340[0,29,T][0]  {0,0,2940,285} [state=00000034]<
    "Some text and a broken image_ "
  >
  Inline(img)(1)@01581340 {2940,-30,1545,345} [state=00000014]<
    Text(-1)@015815B0[0,17,T][0]  {30,30,1485,285} [state=00000014]<
      "the alternate text"
    >
  >
>
Status: NEW → ASSIGNED
Target Milestone: M6 → M7
The image links seem to work for me.  So if this is just the clicking on broken
images thing then that's part of the larger generated content problem.  I'm
working on that but its less serious and won't make M6.
Target Milestone: M7 → M8
Not going to get to the anonymous content fix for M7.  I'll hit it early in M8.
Blocks: 1994
This issue is still occuring in the June 30th Build. (1999063008)
Target Milestone: M8 → M9
This basically an anonymous content bug.  While I realy want to fix this the
other bugs on my M8 list are more critical.  M9 for now.  If I surprise myself
and do it tomorrow it may still make it but I doubt it.
Whiteboard: makingtest erin@imaginet.com
Attached file test for 5349
Attached file new test case
Attached file html version of test
Whiteboard: makingtest erin@imaginet.com → [TESTCASE] erin@imaginet.com
This worked for me.
*** Bug 6091 has been marked as a duplicate of this bug. ***
*** Bug 5964 has been marked as a duplicate of this bug. ***
Whiteboard: [TESTCASE] erin@imaginet.com → [TESTCASE]
Added a new testcase that demonstrates the problem since the previous ones
did not. The problem is still occuring in July 29th build on Windows 98.
(build id: 1999072908)
Target Milestone: M9 → M10
joki at w3c
All the test cases, including that original URL, work fine for me under today's
Win32 build.
whoops...  the last testcase doesn't actually work (clicking on the alt text)...
Sorry for the mistake.
QA Contact: petersen → py8ieh=bugzilla
As agreed with Beth, assigning myself as QA contact for all 'alt text' bugs...
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 5886 ***
Status: RESOLVED → VERIFIED
No longer blocks: 1994
You need to log in before you can comment on or make changes to this bug.