Re-opening Fennec results in infinite load time

RESOLVED WORKSFORME

Status

Fennec Graveyard
General
--
blocker
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

({qablocker})

Fennec 1.1
ARM
Maemo
qablocker

Details

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b5pre)
Gecko/20091212 Firefox/3.6b5pre Fennec/1.0b6pre

Steps to Reproduce:
1. Remove your profile from the device
2. Add a shortcut to Firefox onto the frontscreen
3. Start Fennec
4. Close Fennec
5. Open fennec again using the shortcut

Actual Results:
There are times when Firefox doesn't load at all and other times it takes 20+
seconds on the 2nd time its loaded. The first time its loaded is consistently
~5 seconds.

Comment 1

8 years ago
this issue becomes more impactful when trying to install an addon, and needing to restart to save the changes.   I installed weave addon, restarted, and it sat there for over 5-8 seconds after shutdown on the n900 desktop before restarting again.   As a user, i wasnt sure if i needed to relaunch fennec manually, or that the restart was still working in the background.  

Is there a progress bar or something we can add to indicate the restart is happening?
Tony's issue is a bit different. We are registering all the XPCOM components during an add-on restart. 5-8 seconds ain't bad for that, considering it takes 5-8 secs to simply launch the app.

Comment 3

8 years ago
(In reply to comment #2)
> Tony's issue is a bit different. We are registering all the XPCOM components
> during an add-on restart. 5-8 seconds ain't bad for that, considering it takes
> 5-8 secs to simply launch the app.

Oops, i was way off.  It's more like 30-35 seconds of boot time.   I did an addon uninstall-restart and thats how long it took to restart.
(Reporter)

Updated

8 years ago
Summary: Restarting Fennec results in infinite load time → Re-opening Fennec results in infinite load time
(Reporter)

Updated

8 years ago
Keywords: qablocker
(Reporter)

Comment 4

8 years ago
Hm, this isn't happening to me anymore. Do you see this anymore on the latest nightlies, Tony?

Comment 5

8 years ago
yes, restart is still around 30-35 seconds to reload fennec.   You can test this easily by just enabling/disabling any addons and clicking restart.   i tested 3 different extensions, so its not extension related.

But i should probably open a different bug for this since Mark mentioned its an XPCOM component registration issue.

Comment 6

8 years ago
need to revisit this bug again on latest fennec to see if its still occuring.
(Reporter)

Comment 7

8 years ago
This wfm for the past 3-4 weeks. I'm not sure what might have fixed this, so I'm going to resolve it unless someone else can reproduce it.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.