Closed Bug 535029 Opened 12 years ago Closed 11 years ago

startup crash [@ nsPrefBranch::freeObserverList() | nsPrefBranch::Observe(nsISupports*, char const*, unsigned short const*)]

Categories

(Core :: Preferences: Backend, defect)

1.9.1 Branch
x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 519962

People

(Reporter: wsmwk, Unassigned)

Details

(Keywords: crash)

Crash Data

startup crash [@ nsPrefBranch::freeObserverList() | nsPrefBranch::Observe(nsISupports*, char const*, unsigned short const*)]

Mac sig for bug 519962

bp-9a299578-4992-4de9-bee1-9f3002091203
0	thunderbird-bin	nsPrefBranch::freeObserverList	 modules/libpref/src/nsPrefBranch.cpp:781
1	thunderbird-bin	nsPrefBranch::Observe	modules/libpref/src/nsPrefBranch.cpp:722
2	libxpcom_core.dylib	nsObserverList::NotifyObservers	xpcom/ds/nsObserverList.cpp:128
3	libxpcom_core.dylib	nsObserverService::NotifyObservers	xpcom/ds/nsObserverService.cpp:181
4	libxpcom_core.dylib	mozilla::ShutdownXPCOM	xpcom/build/nsXPComInit.cpp:776
5	thunderbird-bin	ScopedXPCOMStartup::RegisterProfileService	toolkit/xre/nsAppRunner.cpp:956
6	thunderbird-bin	XRE_main	toolkit/xre/nsAppRunner.cpp:3364
7	thunderbird-bin	main	mail/app/nsMailApp.cpp:103
dup of bug 519962? Not XPCOM.
Component: XPCOM → Preferences: Backend
QA Contact: xpcom → preferences-backend
Version: Trunk → 1.9.1 Branch
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 519962
Crash Signature: [@ nsPrefBranch::freeObserverList() | nsPrefBranch::Observe(nsISupports*, char const*, unsigned short const*)]
No longer depends on: 519962
You need to log in before you can comment on or make changes to this bug.