Closed Bug 535049 Opened 10 years ago Closed 10 years ago

Automatically select spell checker language by site language and remember manual changes

Categories

(Firefox :: General, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 338427

People

(Reporter: mozilla-bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091215 Ubuntu/9.10 (karmic) Namoroka/3.6b6pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2b6pre) Gecko/20091215 Ubuntu/9.10 (karmic) Namoroka/3.6b6pre

When I'm visiting an English site, I'm probably going to write my comments in English. When the site I'm visiting speaks German, I'm most likely going to write my comments in German.

So, why should I change the language of the spell checker manually? If the language is stored in the page's source code, Firefox could automatically select the corresponding spell checker language.

Additionally, Firefox even may remember the set language on a per-site-base and restore it if applicable.

Reproducible: Always

Steps to Reproduce:
1. visit a page with text input elements
2. type some text and note spell checker language, change it afterwards
3. visit another page with input elements, type some text, note spell checker language and restore it
4. visit first page
Actual Results:  
The language on the first page is reset, too.

Expected Results:  
It's most likely that the input on the first site will be in the same language as on the first visit, so the language should stay the same. The same applies to the second page (and the second language).
quite old wishes:
Bug 338427: page language detection
Bug 360668: site specific setting
=> duping.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 338427
You need to log in before you can comment on or make changes to this bug.